Bug 416121 - Can't open configuration file [(null)]
Can't open configuration file [(null)]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 16:26 EST by Curtis Doty
Modified: 2016-07-26 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 16:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
seed proper perms on vtysh.conf (1.48 KB, patch)
2007-12-07 16:26 EST, Curtis Doty
no flags Details | Diff

  None (edit)
Description Curtis Doty 2007-12-07 16:26:44 EST
$ vtysh

Hello, this is Quagga (version 0.99.9).
Copyright 1996-2005 Kunihiro Ishiguro, et al.

localhost# show start
Can't open configuration file [(null)]

This is because rpm creates /etc/quagga/vtysh.conf with wrong perms. Workaround
is to chown quagga:quaggavt vtysh.conf just like the vtysh.conf.sample already is.

Proper fix is probably something like the *as-yet-untested* specfile patch
attached. Thanks!
Comment 1 Curtis Doty 2007-12-07 16:26:44 EST
Created attachment 281631 [details]
seed proper perms on vtysh.conf
Comment 2 Martin Nagy 2008-03-05 07:18:46 EST
Hi, I'm using default settings and when executing vtysh as root I don't see this
problem. When I try using my regular (wheel) user, vtysh just quietly quit. Then
I uncommented this line in /etc/pam.d/quagga:
auth       sufficient   pam_wheel.so trust use_uid

And now vtysh claims it cannot connect to any daemons. strace revealed that:
connect(3, {sa_family=AF_FILE, path="/var/run/quagga/zebra.vty"}, 27) = -1
EACCES (Permission denied)

Just to make it short, your fix is simple and reasonable, but I would like to
know, what is the standard way to configure quagga so that a regular user can
use vtysh? I need this so I can reproduce this bug and verify the fix. Your help
would be much appreciated. Thanks.
Comment 3 Curtis Doty 2008-03-05 10:38:12 EST
Make that user *both* a member of wheel and quaggavt.
Comment 4 Martin Nagy 2008-03-05 10:50:16 EST
Thank you for your quick response, I can now reproduce this. I'll fix this shortly.
Comment 5 Martin Nagy 2008-03-05 16:19:59 EST
Fixed in rawhide: quagga-0.99.9-6.fc9
Thanks for reporting this and for patch.

Note You need to log in before you can comment on or make changes to this bug.