Bug 416151 - Directory listing fails. Only half is given on some dirs, but no error at client side!
Directory listing fails. Only half is given on some dirs, but no error at cli...
Status: CLOSED DUPLICATE of bug 410441
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
6
i686 Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 16:40 EST by markus
Modified: 2007-12-08 09:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-08 09:25:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Deleted all files in log directory, and then done one access (which fails, se above) (8.62 KB, application/zip)
2007-12-07 16:40 EST, markus
no flags Details

  None (edit)
Description markus 2007-12-07 16:40:35 EST
Description of problem:
When certain directories are listed only part of the contents are listed.
Sometimes one file (the last to be sent?) is look strange (chopped name, or 
zero-sized). Note that is is on the clientside, where no error is received. I 
thought I been hacked when half of my files went missing!

Version-Release number of selected component (if applicable):
The problem began with the lasted update of samba.
samba-3.0.24-9.fc6

How reproducible:
Hard to tell since I do not know why it happen. 

Steps to Reproduce:
1. List a directory on samba server. (Tested with Vista and XP client)
2. Look for a file with an incorrect name or size.
3. Check fileproperties on incorrect file. Should fail.
  
Actual results:
Some files are missing in the listing, and at least one file is displayed 
incorrect. I really can't understand why it only happens on some directories, 
and not all.

Expected results:
Complete and correct directory listing transfered and displayed.

Additional info:
See logs
Comment 1 markus 2007-12-07 16:40:35 EST
Created attachment 281651 [details]
Deleted all files in log directory, and then done one access (which fails, se above)
Comment 2 markus 2007-12-07 17:48:09 EST
Been playing around some more. This problem has to do with large directory 
listings. Adding files to an directory will get samba listing to fail at a 
point.

Here is a better way to reproduce:
1 Create directory "Test" in a share.
2 Create file "Test.txt" in the directory.
3 Copy file (Ctrl-C) "Test.txt", and paste it.
  There will now be two files, "Test.txt" and "Test - Kopia".
4 Mark and copy all files (Ctrl-C) and paste.
  (Step 2: "Test.txt", "Test - Kopia.txt", "Test - Kopia - Kopia.txt",
   "Test - Kopia (2).txt")
5 Run step 4 until directory contains 128 files. (7 steps totaly)

Results: Listing is crippled once again. Only 97 files are shown at client,
and one of the files is not displayed correctly, and all operations on it fails.
(file do not exist).

When deleting files in directory test, there comes a point where listing become 
correct and complete.
 
Comment 3 markus 2007-12-08 07:45:38 EST
Same problem as 410441. Sorry for bothering. SOLVED.
Comment 4 Simo Sorce 2007-12-08 09:25:42 EST

*** This bug has been marked as a duplicate of 410441 ***

Note You need to log in before you can comment on or make changes to this bug.