Bug 416361 - Gnome session save regression for multiple xterm instances
Gnome session save regression for multiple xterm instances
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 01:51 EST by Karl Czajkowski
Modified: 2007-12-17 10:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 10:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Czajkowski 2007-12-08 01:51:37 EST
Description of problem:

After saving a session with multiple xterms at different positions and sizes, 
a new session momentarily shows the xterms at their correct places and then
rapidly smashes them into one position (on top of each other).  It does this
identically for each virtual desktop, re-positioning the instances that were
initially correctly placed on that desktop, as if using relative coordinates
within the virtual desktop.

Version-Release number of selected component (if applicable):

gnome-session-2.20.1-1.fc8
xterm-229-2.fc8

How reproducible:

Nearly always. I have seen some odd behaviors where a login does not do this
extra smashing of positions and xterms remain where they belong, but this has
only happened coincidentally with other strange behaviors such as a
System->Logout->Logout request failing to have any effect. I am left with the
impression that there are some race-conditions in the session handling.

I see this consistently on a single processor laptop install. I am not positive,
but I think it seems more "random" on a 4-core workstation.  But, I have not
done enough logout/login cycles to really have statistically meaningful
observations...

Steps to Reproduce:
1. Login to a new session with no applications
2. Open several xterm processes and position them
3. Do a gnome-session-save
4. Logout
5. Login
  
Actual results:

Xterm windows misplaced.

Expected results:

All xterm windows at same places where they were when session was saved.

Additional info:

This is a regression.  There have been many problems in past Fedora releases but
this behavior was fixed in Fedora 7 and lulled me into using Gnome again instead
of XFCE (where xterms are handled correctly).  It is unfortunate that there are
not regression tests to notice this recurring problem before changes are
released... I'm not enough of an X hacker to suggest how to write an automated
test to validate geometry of windows in saved sessions, but I think it would be
wise to try, given the recurring nature of this problem...
Comment 1 Karl Czajkowski 2007-12-11 04:27:22 EST
Since reporting this, I've seen sessions come back properly.  I am not sure
whether an update was installed that fixed it, or whether perhaps the original
problem had to do with home directory settings saved from F7 and then loaded
under F8... I cannot seem to reproduce the failure now.
Comment 2 Ray Strode [halfline] 2007-12-17 10:58:17 EST
excellent.  Since you've been the only reporter, I'm going to close this out,
but please reopen if it happens again.

Note You need to log in before you can comment on or make changes to this bug.