Bug 416411 - Problem updating kernel
Problem updating kernel
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 04:37 EST by Braden McDaniel
Modified: 2014-01-21 18:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 11:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2007-12-08 04:37:56 EST
Since updating to 3.2.8-1.fc8, I'm consistently seeing the following when I
attempt to update the kernel (which, in light of the predicate issue in bug
330711, I am inclined to think is not simply a problem with the mirrors):

# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 0:100.14.19-19.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.23.8-63.fc8 for package: kmod-nvidia
---> Package kernel-devel.x86_64 0:2.6.23.8-63.fc8 set to be installed
---> Package kernel.x86_64 0:2.6.23.8-63.fc8 set to be installed
---> Package kernel-headers.x86_64 0:2.6.23.8-63.fc8 set to be updated
--> Running transaction check
---> Package kmod-nvidia-2.6.23.8-63.fc8.x86_64 0:100.14.19-19.lvn8 set to be
updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel-devel.x86_64 0:2.6.23.1-42.fc8 set to be erased
---> Package kmod-nvidia-2.6.23.8-63.fc8.x86_64 0:100.14.19-19.lvn8 set to be
updated
---> Package kmod-nvidia.x86_64 0:100.14.19-19.lvn8 set to be updated
---> Package kernel-devel.x86_64 0:2.6.23.8-63.fc8 set to be installed
---> Package kernel.x86_64 0:2.6.23.8-63.fc8 set to be installed
---> Package kernel-headers.x86_64 0:2.6.23.8-63.fc8 set to be updated
---> Package kernel.x86_64 0:2.6.23.1-42.fc8 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 kernel-devel            x86_64     2.6.23.8-63.fc8  updates           4.9 M
Updating:
 kernel-headers          x86_64     2.6.23.8-63.fc8  updates           705 k
 kmod-nvidia             x86_64     100.14.19-19.lvn8  livna              21 k
Removing:
 kernel                  x86_64     2.6.23.1-42.fc8  installed          62 M
 kernel-devel            x86_64     2.6.23.1-42.fc8  installed          32 M
Installing for dependencies:
 kernel                  x86_64     2.6.23.8-63.fc8  updates            17 M
 kmod-nvidia-2.6.23.8-63.fc8  x86_64     100.14.19-19.lvn8  livna             2.1 M

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       2 Package(s)         
Remove       2 Package(s)         

Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): kernel-headers-2.6 100% |=========================| 705 kB    00:01     
http://mirror.anl.gov/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.nuvio.com/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 14] HTTP Error 503: Service Temporarily Unavailable
Trying other mirror.
http://mirror.lib.ucdavis.edu/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.usf.edu/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.steadfast.net/fedora/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cc.vt.edu/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://www.gtlib.gatech.edu/pub/fedora.redhat/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.web-ster.com/fedora/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.unl.edu/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.reflected.net/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(1/3): kernel-headers-2.6 100% |=========================| 705 kB    00:00     
ftp://ftp.software.umn.edu/linux/fedora/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://fedora.mirror.facebook.com/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.osuosl.org/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(1/3): kernel-headers-2.6 100% |=========================| 705 kB    00:00     
ftp://mirror.colorado.edu/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://kdeforge.unl.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.linux.ncsu.edu/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://fedora.mirror.iweb.ca/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.kernel.org/fedora/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.cat.pdx.edu/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.hiwaay.net/pub/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(1/3): kernel-headers-2.6 100% |=========================| 705 kB    00:00     
ftp://ftp.uci.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://srl.cs.jhu.edu/YUM/fedora/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.usu.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/updates/8/x86_64/kernel-headers-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(2/3): kernel-2.6.23.8-63 100% |=========================|  17 MB    00:31     
http://mirror.anl.gov/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.nuvio.com/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 14] HTTP Error 503: Service Temporarily Unavailable
Trying other mirror.
http://mirror.lib.ucdavis.edu/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.usf.edu/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.steadfast.net/fedora/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cc.vt.edu/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://www.gtlib.gatech.edu/pub/fedora.redhat/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.web-ster.com/fedora/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.unl.edu/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.reflected.net/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(2/3): kernel-2.6.23.8-63 100% |=========================|  17 MB    00:00     
ftp://ftp.software.umn.edu/linux/fedora/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://fedora.mirror.facebook.com/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.osuosl.org/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(2/3): kernel-2.6.23.8-63 100% |=========================|  17 MB    00:00     
ftp://mirror.colorado.edu/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://kdeforge.unl.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.linux.ncsu.edu/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://fedora.mirror.iweb.ca/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.kernel.org/fedora/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.cat.pdx.edu/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.hiwaay.net/pub/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(2/3): kernel-2.6.23.8-63 100% |=========================|  17 MB    00:00     
ftp://ftp.uci.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://srl.cs.jhu.edu/YUM/fedora/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.usu.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/updates/8/x86_64/kernel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(3/3): kernel-devel-2.6.2 100% |=========================| 4.9 MB    00:14     
http://mirror.anl.gov/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.nuvio.com/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 14] HTTP Error 503: Service Temporarily Unavailable
Trying other mirror.
http://mirror.lib.ucdavis.edu/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.usf.edu/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.steadfast.net/fedora/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cc.vt.edu/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://www.gtlib.gatech.edu/pub/fedora.redhat/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.web-ster.com/fedora/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.unl.edu/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.reflected.net/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(3/3): kernel-devel-2.6.2 100% |=========================| 4.9 MB    00:00     
ftp://ftp.software.umn.edu/linux/fedora/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://fedora.mirror.facebook.com/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.osuosl.org/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(3/3): kernel-devel-2.6.2 100% |=========================| 4.9 MB    00:00     
ftp://mirror.colorado.edu/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://kdeforge.unl.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://ftp.linux.ncsu.edu/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://fedora.mirror.iweb.ca/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.kernel.org/fedora/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirrors.cat.pdx.edu/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.hiwaay.net/pub/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
(3/3): kernel-devel-2.6.2 100% |=========================| 4.9 MB    00:00     
ftp://ftp.uci.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
http://srl.cs.jhu.edu/YUM/fedora/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.usu.edu/mirrors/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.
http://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/updates/8/x86_64/kernel-devel-2.6.23.8-63.fc8.x86_64.rpm:
[Errno 9] Requested Range Not Satisfiable
Trying other mirror.


Error Downloading Packages:
  kernel-headers - 2.6.23.8-63.fc8.x86_64: failure:
kernel-headers-2.6.23.8-63.fc8.x86_64.rpm from updates: [Errno 256] No more
mirrors to try.
  kernel-devel - 2.6.23.8-63.fc8.x86_64: failure:
kernel-devel-2.6.23.8-63.fc8.x86_64.rpm from updates: [Errno 256] No more
mirrors to try.
  kernel - 2.6.23.8-63.fc8.x86_64: failure: kernel-2.6.23.8-63.fc8.x86_64.rpm
from updates: [Errno 256] No more mirrors to try.
Comment 1 Seth Vidal 2007-12-09 17:05:41 EST
Is there a proxy involved here? Or has your internet access service recently
changed somehow?

Comment 2 Braden McDaniel 2007-12-09 17:32:35 EST
No.

And I am able to update other packages just fine. It's just when attempting to
update the kernel and kmod-nvidia that this happens. (These are the same
packages that bug 330711 blocked updating via yum.)
Comment 3 Braden McDaniel 2007-12-10 11:56:54 EST
My latest attempt to update these packages (in conjunction with an update to
livna-config-display) was successful.

I'm not sure what changed. Perhaps yum finally let go of some bogus
configuration data.
Comment 4 Seth Vidal 2007-12-10 12:00:59 EST
I'm glad it's working but what is more likely is a transient network error b/c
yum doesn't have any configuration data that it holds onto that would cause the
above problems.

Note You need to log in before you can comment on or make changes to this bug.