Bug 416441 - EXA graphics acceleration: incorrect background colours in Nautilus windows
EXA graphics acceleration: incorrect background colours in Nautilus windows
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 05:54 EST by mkpyc9
Modified: 2008-03-21 18:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0.0-44.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 18:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg configuration file (1.15 KB, application/octet-stream)
2007-12-08 05:54 EST, mkpyc9
no flags Details
Generated by xorg.conf specifying EXA (55.86 KB, text/plain)
2008-02-05 11:22 EST, mkpyc9
no flags Details
Generated when starting X with no xorg.conf (58.03 KB, text/plain)
2008-02-05 11:22 EST, mkpyc9
no flags Details

  None (edit)
Description mkpyc9 2007-12-08 05:54:13 EST
Description of problem:

If the EXA acceleration method is chosen over XAA, all Nautilus windows take on
'random' background colours. Using the Nautilus colour preferences dialogue,
attempting to set the background to white makes no difference, the 'random'
colour remains unchanged, whereas attempting to set the background to black will
change the colour, but not to the intended black. I am using the default Fedora
8 theme, and the problem afflicts both composited and non-composited desktops.

Version-Release number of selected component (if applicable):

I am not sure whether this is a Nautilus or Xorg problem - EXA is known to be
occasionally problematic 


How reproducible:

Always


Steps to Reproduce:
1.Toggle commented-out line "AccelMethod" in attached xorg.conf
2.startx
3.
  
Actual results:

With EXA enabled, clicking on 'Home' on main menu bar will open window with
apparently arbitrary background colour. Drilling down through the directory
hierarchy will keep producing new windows with new background colours. The
problem also affects Nautilus in its System Tools->File Browser mode. 

Expected results:

Default theme background colour should be used.


Additional info:

Graphics card Mobility Radeon 9200, using open radeon driver.
Comment 1 mkpyc9 2007-12-08 05:54:13 EST
Created attachment 281971 [details]
Xorg configuration file
Comment 2 Matěj Cepl 2008-01-31 11:41:53 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachment using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 mkpyc9 2008-02-05 11:16:27 EST
Attached are the requested two Xorg.log files:

1) Xorg.log.exa (generated by xorg.conf specifying EXA)

2) Xorg.log.noconf (generated when starting X with no xorg.conf)
Comment 4 mkpyc9 2008-02-05 11:22:07 EST
Created attachment 294010 [details]
Generated by xorg.conf specifying EXA
Comment 5 mkpyc9 2008-02-05 11:22:46 EST
Created attachment 294011 [details]
Generated when starting X with no xorg.conf
Comment 6 Fedora Update System 2008-03-21 18:12:15 EDT
xorg-x11-server-1.3.0.0-44.fc8, xorg-x11-drv-amd-2.7.7.7-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.