Bug 416561 - pyzor module does not allow integration of SpamAssassin with pyzor
pyzor module does not allow integration of SpamAssassin with pyzor
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 09:36 EST by Max Kanat-Alexander
Modified: 2008-05-21 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2007-12-08 09:36:07 EST
When integrating SpamAssassin any pyzor, I get the following denials:

type=AVC msg=audit(1197124376.168:4249): avc:  denied  { write } for  pid=20760
comm="pyzor" name="smtpd" dev=sda3 ino=26611341
scontext=user_u:system_r:pyzor_t:s0 tcontext=user_u:object_r:user_home_dir_t:s0
tclass=dir
type=AVC msg=audit(1197124376.168:4249): avc:  denied  { add_name } for 
pid=20760 comm="pyzor" name=".pyzor" scontext=user_u:system_r:pyzor_t:s0
tcontext=user_u:object_r:user_home_dir_t:s0 tclass=dir
type=AVC msg=audit(1197124376.168:4249): avc:  denied  { create } for  pid=20760
comm="pyzor" name=".pyzor" scontext=user_u:system_r:pyzor_t:s0
tcontext=user_u:object_r:user_home_dir_t:s0 tclass=dir
type=AVC msg=audit(1197124376.411:4250): avc:  denied  { name_connect } for 
pid=20760 comm="pyzor" dest=80 scontext=user_u:system_r:pyzor_t:s0
tcontext=system_u:object_r:http_port_t:s0 tclass=tcp_socket
type=AVC msg=audit(1197124376.515:4251): avc:  denied  { create } for  pid=20760
comm="pyzor" name="servers" scontext=user_u:system_r:pyzor_t:s0
tcontext=user_u:object_r:user_home_dir_t:s0 tclass=file
type=AVC msg=audit(1197124376.515:4252): avc:  denied  { getattr } for 
pid=20760 comm="pyzor" path="/home/smtpd/.pyzor/servers" dev=sda3 ino=26611404
scontext=user_u:system_r:pyzor_t:s0 tcontext=user_u:object_r:user_home_dir_t:s0
tclass=file
type=AVC msg=audit(1197124376.516:4253): avc:  denied  { write } for  pid=20760
comm="pyzor" path="/home/smtpd/.pyzor/servers" dev=sda3 ino=26611404
scontext=user_u:system_r:pyzor_t:s0 tcontext=user_u:object_r:user_home_dir_t:s0
tclass=file
type=AVC msg=audit(1197124376.516:4254): avc:  denied  { read } for  pid=20760
comm="pyzor" name="servers" dev=sda3 ino=26611404
scontext=user_u:system_r:pyzor_t:s0 tcontext=user_u:object_r:user_home_dir_t:s0
tclass=file


Most people probably don't get these because pyzor requires additional
configuration after installing SpamAssassin--configuration that isn't documented
or discoverable unless you run spamd in debug mode (with the -D argument) and
notice why it's failing to use pyzor.
Comment 1 Warren Togami 2007-12-08 12:07:37 EST
Does Fedora have the policy to handle this?
Comment 2 Max Kanat-Alexander 2007-12-08 18:15:19 EST
Just looking it over, Fedora 8 seems to have policy for pyzor to handle files in
a home directory. I don't see a policy that allows it to open the TCP socket,
but I'm not an expert at reading SELinux module policy.
Comment 3 Daniel Walsh 2007-12-10 17:02:04 EST
FIxed in selinux-policy-2.4.6-107.el5.src.rpm
Comment 4 RHEL Product and Program Management 2007-12-10 17:04:18 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Max Kanat-Alexander 2007-12-11 14:27:56 EST
Today I have an additional audit message in my log, but it's only happened once
in the entire day. Apparently sometimes spamd needs to signal pyzor, but I can't
figure out why. I don't have spamassassin debug logging on anymore, and the
message isn't reproducible in any easy way, apparently.

type=AVC msg=audit(1197399863.276:11484): avc:  denied  { signal } for  pid=5136
comm="spamd" scontext=user_u:system_r:spamd_t:s0
tcontext=user_u:system_r:pyzor_t:s0 tclass=process
Comment 6 Daniel Walsh 2007-12-13 16:09:16 EST
That should be allowed in the selinux-policy-2.4.6-107.el5.src.rpm policy.

Preview available on http://people.redhat.com/dwalsh/SELinux/RHEl5
Comment 10 errata-xmlrpc 2008-05-21 12:06:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html

Note You need to log in before you can comment on or make changes to this bug.