Bug 416581 - NTP multicast client does not work
NTP multicast client does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 11:02 EST by Vlado Potisk
Modified: 2007-12-12 11:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 11:45:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ntpd -n -D 5 (18.31 KB, text/plain)
2007-12-11 09:50 EST, Vlado Potisk
no flags Details

  None (edit)
Description Vlado Potisk 2007-12-08 11:02:17 EST
Description of problem:
NTP multicast client doesn't work.

Version-Release number of selected component (if applicable):
ntp-4.2.4p2-6

How reproducible:
Always

Steps to Reproduce:
1. configure NTP as multicast client and start it
  
Actual results:
NTP started normally, but time get's never synced, ntpq shows no associations.
There are error in logs:
ntpd[3893]: Listening on interface #6 multicast, 224.0.1.1#123 Enabled
ntpd[3893]: setsockopt IP_ADD_MEMBERSHIP failure: No such device on socket 22,
addr 224.0.1.1 for 10100e0 / 0 (224.0.1.1)
ntpd[3893]: Failed to add Multicast Listener 224.0.1.1

Expected results:
Time synced to the multicast server.

Additional info:
The same setup configured as broadcast client works fine (that's the workaround
I'm using now). Fedora Core 6 multicast client works fine on the same LAN.
Comment 1 Miroslav Lichvar 2007-12-11 06:57:29 EST
It works for me. Any chance you are using a custom kernel?

If not, please attach here the output of /usr/sbin/ntpd -n -D 5.
Comment 2 Vlado Potisk 2007-12-11 09:49:33 EST
No custom kernel.

I have now another Fedora 8 machine (different hardware) that has no multicast
problem with exactly the same config. Maybe is the problem hardware related. The
computer in question has Intel D201GLY maiboard with integrated SiS900 ethernet
card.
Comment 3 Vlado Potisk 2007-12-11 09:50:49 EST
Created attachment 284111 [details]
output of ntpd -n -D 5
Comment 4 Miroslav Lichvar 2007-12-12 10:54:22 EST
The error means kernel couldn't choose an interface for the multicast group.
Maybe the default route is missing? Does it work when you add the following route?

route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0
Comment 5 Vlado Potisk 2007-12-12 11:45:29 EST
Yes that was it ! I do appreciate your help.

The computer is behind a proxying firewall, there is no real route out. The
other host has the default route (not usable, but present), that's why that one
was working.

I knew that a route for the 224 network is important for sending multicast
traffic, but I did not know it is needed for receiving it too. Sorry for this
false bug report, I'm closing it now.

Note You need to log in before you can comment on or make changes to this bug.