Bug 416791 - Regressions: s-c-d does not work when run as non root user on Dell XPS400 with write-combining range warning
Regressions: s-c-d does not work when run as non root user on Dell XPS400 wit...
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-display (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-12-08 15:21 EST by R P Herrold
Modified: 2008-05-27 16:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-27 16:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
std-out/stderr log from 'startx' with Matrox driver (1.55 KB, text/plain)
2007-12-08 15:26 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2007-12-08 15:21:51 EST
Description of problem:

I now get an X configuration which works as root, but not as non-root, similar
to that reported in bug: 238508;  the error occurs with both the i810 driver
which is the onboard Intel 965 chipset, which seems to call for the i810 driver.  

This is a regression in function from the setup shipped in RHEL 5

I tried using an add in PCI Matrox card, to see if it was 810 driver specific
(which seems to be mentioned in several s-c-d bugs)., but the issue persists
when starting X as non-root with a configuration file made by s-c-d

I will attach trace if you wish

I can build and install s-c-d from rawhide if you wish; alternatively a test
candidate is file for me to rebuild from SRPM as well.

The unit in our stable with this issue is unit: 231

Strangely it all worked without an /etc/X11/xorg.conf  pre-RHEL 5.1, with the
5.0 product

errors and warnings in that file are as follows:

[herrold@dhcp-231 log]$ grep WW Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) VESA(0): Failed to set up write-combining range (0xd0000000,0x400000)
(WW) <default pointer>: No Device specified, looking for one...
[herrold@dhcp-231 log]$ grep EE Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
[herrold@dhcp-231 log]$ 238508 

Version-Release number of selected component (if applicable):


How reproducible:

remove old /etc/Xqq/xorg.conf file
run s-c-d
try to startx as non-root

Steps to Reproduce:

as above 

Actual results:

-- X starts as root, and not as non-root.

Expected results:

startx should work for all users after re-running s-c-d
Comment 1 R P Herrold 2007-12-08 15:26:19 EST
Created attachment 282091 [details]
std-out/stderr log from 'startx' with Matrox driver

note the 

(WW) MGA(0): Failed to set up write-combining range

messages -- these are present with the i810 driver as well
Comment 2 Matěj Cepl 2007-12-13 18:24:10 EST
We could probably use whole logs, not only greps through them. Please attach
your X server config file (/etc/X11/xorg.conf) and X server log file
(/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Matěj Cepl 2008-01-17 07:25:21 EST
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 4 R P Herrold 2008-04-08 14:03:20 EDT
I am suppy -- the email requesting update was missied -- I will attend to this
as soon as I can set up a test environment - please give me 2 weeks.

Comment 5 Matěj Cepl 2008-04-09 07:15:55 EDT
Request granted :-)
Comment 6 R P Herrold 2008-05-12 15:44:13 EDT
setting test unit up today
Comment 7 R P Herrold 2008-05-27 10:50:18 EDT
needed hardware left my control -- cannot test further -- sorry

I cannot close this bug with my bugzilla permissions, even though I was the
original reporter -- please do so for me

thank you
Comment 8 Matěj Cepl 2008-05-27 16:46:09 EDT
Thanks for letting us know.

Since there is no apparently way how to obtain are sufficient details for
investigating this issue further, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional


Note You need to log in before you can comment on or make changes to this bug.