Bug 416821 - (TB40619167) TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object has no attribute 'card'
TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object has no a...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 428575 434565 TB35871046 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 16:02 EST by Joerg Michel
Modified: 2008-04-22 18:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
instant fix (5.17 KB, application/x-gzip)
2008-01-19 14:02 EST, Stephan Ebelt
no flags Details
the changes made in the previous attachment as a patch (3.46 KB, patch)
2008-04-07 05:19 EDT, Paul Bolle
no flags Details | Diff
Update of sys...-conf..-network to 1.5.5... (882 bytes, application/octet-stream)
2008-04-10 04:03 EDT, Klacar Nebojsa
no flags Details

  None (edit)
Description Joerg Michel 2007-12-08 16:02:59 EST
Component: system-config-network
Version: 1.4.3
Summary: TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object
has no attribute 'card'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
735, in on_addButton_clicked
    self.addButtonFunc[self.active_page](button)
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
1532, in on_hardwareAddButton_clicked
    if self.showHardwareDialog(hw) == gtk.RESPONSE_OK:
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
1563, in showHardwareDialog
    dl = hw.getDialog()
  File "/usr/share/system-config-network/netconfpkg/plugins/NCHWIsdn.py", line
34, in getDialog
    return _hwIsdnDialog(self).xml.get_widget("Dialog")
  File "/usr/share/system-config-network/netconfpkg/gui/isdnhardware.py", line
56, in __init__
    self.setup()
  File "/usr/share/system-config-network/netconfpkg/gui/isdnhardware.py", line
207, in setup
    cardlist = NCisdnhardware.card.keys()
AttributeError: 'module' object has no attribute 'card'

Local variables in innermost frame:
self: <netconfpkg.gui.isdnhardware.isdnHardwareDialog instance at 0xa6134ac>
Comment 1 Andreas Haupt 2007-12-10 04:28:03 EST
I think this bug should really get a higher priority as it prevents users from
using ISDN hardware under Fedora 8.

The only chance you have is to take /etc/sysconfig/isdncard from an older Fedora
release (or you know how it should look like...).
Comment 2 Stephan Ebelt 2008-01-19 14:02:49 EST
Created attachment 292270 [details]
instant fix

this fix worksForMe(TM), not sure if its the correct way to do... I do not
overlook the code and was in a hurry...
Comment 3 Harald Hoyer 2008-03-31 06:44:29 EDT
*** Bug 434565 has been marked as a duplicate of this bug. ***
Comment 4 Paul Bolle 2008-04-07 05:19:33 EDT
Created attachment 301486 [details]
the changes made in the previous attachment as a patch

The attachment of comment #2 is called no-card-attribute-fix.tar.gz but should
actually be called no-card-attribute-fix.tar.gz.gz! It consist of two files. To
save others some trouble, I've recreated it as a 80 line patch (ignoring
changes in whitespace).

Note that I haven't yet tested that patch (that should be the next step).
Comment 5 Harald Hoyer 2008-04-07 09:47:34 EDT
*** Bug 436401 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2008-04-07 10:34:23 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 7 Jiri Moskovcak 2008-04-08 09:51:59 EDT
*** Bug 428575 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-04-09 01:19:40 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 9 Klacar Nebojsa 2008-04-10 04:03:38 EDT
Created attachment 301951 [details]
Update of sys...-conf..-network to 1.5.5...

Following advice related to the ISDN bug in fc8, I have updated
system-config-network to 1.5.5, via YUM command, via provided link for testing
repositories. For me, nothing has changed i.e. the same problem still persists.
Comment 10 Harald Hoyer 2008-04-10 05:54:33 EDT
(In reply to comment #9)
> Created an attachment (id=301951) [edit]
> Update of sys...-conf..-network to 1.5.5...
> 
> Following advice related to the ISDN bug in fc8, I have updated
> system-config-network to 1.5.5, via YUM command, via provided link for testing
> repositories. For me, nothing has changed i.e. the same problem still persists.
> 

can you show me your new traceback please?
Comment 11 Klacar Nebojsa 2008-04-11 03:45:43 EDT
Component: system-config-network
Version: 1.5.5
Summary: TB35871046 IsdnInterface.py:162:setup:AttributeError: 'module' object
has no attribute 'card'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 121, in on_start_page_next
    druid_pages = interface.get_druids()
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
105, in get_druids
    if not self.init_gui():
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
74, in init_gui
    self.setup()
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
162, in setup
    cardlist = NCisdnhardware.card.keys()
AttributeError: 'module' object has no attribute 'card'

Local variables in innermost frame:
self: <netconfpkg.gui.IsdnInterface.IsdnInterface instance at 0xa5e246c>
Comment 12 Harald Hoyer 2008-04-11 05:07:02 EDT
quickfix:
# perl -pi -e 's#NCisdnhardware\.card#NCisdnhardware._card#g'
/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py

will make a new update.
Comment 13 Fedora Update System 2008-04-22 18:38:27 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.