Bug 416941 - gphoto2 build problem (alpha only?)
gphoto2 build problem (alpha only?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
8
alpha Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 18:54 EST by Oliver Falk
Modified: 2013-07-02 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 00:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-12-08 18:54:16 EST
Can you please have a look at this build log:

http://buildsys.zero42.at/koji/getfile?taskID=74990&name=build.log

Thx
Comment 1 Jindrich Novy 2007-12-09 03:12:41 EST
Oliver, it seems like you have incorrect glibc-headers installed in buildroot as
IXANY isn't declared in %{_includedir}/bits/termios.h. This is all I can guess
from the build log you posted here.

Try to add somthing like:
#ifdef __ALPHA__
#  define IXANY   0004000
#endif

after the #include <termios.h> in
gphoto2-2.4.0/libgphoto2-2.4.0/libgphoto2_port/serial/unix.c and you will see.
Comment 2 Jindrich Novy 2007-12-09 03:15:59 EST
FYI: http://opengroup.org/onlinepubs/007908799/xbd/termios.html
Comment 3 Oliver Falk 2007-12-09 04:46:44 EST
Well. I do see it defined:
[oliver@gosa F-8]$ grep -r IXANY /usr/include/{asm,bits}/*
/usr/include/asm/termbits.h:#define IXANY       0004000
/usr/include/bits/termios.h:# define IXANY              0004000

In bits/termios.h the define is inside of some ifdef __USE_BSD. But __USE_BSD
isn't enabled somewhere, is it?

The define is also commented with: /* POSIX.1 doesn't want these... */. - On
Alpha. On x86 I don't see this idef or the comment ?!
Comment 4 Jindrich Novy 2007-12-09 05:01:02 EST
rpm -q glibc-headers ?
Comment 5 Jindrich Novy 2007-12-09 05:02:20 EST
... and also rpm -q kernel-headers please :)
Comment 6 Oliver Falk 2007-12-09 07:54:06 EST
[oliver@gosa work]$ rpm -q kernel-headers
kernel-headers-2.6.23.1-58.fc8axp
Comment 7 Oliver Falk 2007-12-09 16:42:55 EST
#ifndef IXANY
#  define IXANY   0004000
#endif

Is what I patched in. Just in case some other arch also has problems...

If you don't matter, please add appropriate patch (with your ifdef, or my ifndef
- I don't mind).

The question with the headers - of course - is still open.
Comment 8 Jindrich Novy 2008-02-25 00:52:45 EST
I applied the ifndef in rawhide, it seems to be safer.

Note You need to log in before you can comment on or make changes to this bug.