Bug 417301 - LiveCD does not create "liveinst" icon on "Fedora Live" user desktop
Summary: LiveCD does not create "liveinst" icon on "Fedora Live" user desktop
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-09 16:14 UTC by Luis Felipe Marzagao
Modified: 2013-01-10 04:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 01:59:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luis Felipe Marzagao 2007-12-09 16:14:22 UTC
Description of problem:
The liveinst icon does not get created if you build a LiveCD with other language
than english in the ks file. 

Version-Release number of selected component (if applicable):
Not applicable, any livecd.

How reproducible:
always

Steps to Reproduce:
1. Define lang pt_BR, for example, in a livecd ks file
2. Build the livecd with livecd-creator
3. Boot with created livecd
  
Actual results:
"liveinst" icon does not appear. You have to manually type "liveinst" in a terminal.


Expected results:
liveinst icon should appear, as it happens with lang en_US.

Additional info:
I think it happens because the name of "Desktop" folder is different in other
languages. On pt_BR, for example, it's "Área de Trabalho" instead of "Desktop".
So maybe the file liveinst.desktop is not being copied, because the folder
"Desktop" is not there. Just gessing.

Comment 1 Jeremy Katz 2007-12-10 15:55:08 UTC
It should be getting copied and taking into account the localized directory
name... can you manually run
  sh -x /etc/X11/xinit/xinitrc.d/zz-liveinst.sh

and provide the output?

Comment 2 Luis Felipe Marzagao 2007-12-10 23:05:22 UTC
Hello, Jeremy:

Here's the output:

[fedora@localhost ~]$ sh -x /etc/X11/xinit/xinitrc.d/zz-liveinst.sh 
+ '[' -b /dev/live-osimg ']'
+ test -f /home/fedora/.config/user-dirs.dirs
+ source /home/fedora/.config/user-dirs.dirs
++ XDG_DESKTOP_DIR='/home/fedora/Ãrea de Trabalho'
++ XDG_DOWNLOAD_DIR=/home/fedora/Download
++ XDG_TEMPLATES_DIR=/home/fedora/Modelos
++ XDG_PUBLICSHARE_DIR=/home/fedora/Público
++ XDG_DOCUMENTS_DIR=/home/fedora/Documentos
++ XDG_MUSIC_DIR=/home/fedora/Música
++ XDG_PICTURES_DIR=/home/fedora/Imagens
++ XDG_VIDEOS_DIR=/home/fedora/Vídeos
+ cp /usr/share/applications/liveinst.desktop $'/home/fedora/Ã\201rea' de Trabalho
cp: target `Trabalho' is not a directory

The problem are the spaces in the desktop folder name ("Área de Trabalho"). So I
put the variable inside quotes it works:

cp /usr/share/applications/liveinst.desktop "${XDG_DESKTOP_DIR:-$HOME/Desktop}"


Comment 3 Luis Felipe Marzagao 2007-12-10 23:07:10 UTC
Oh, here´s the output of the successful changed script:

[fedora@localhost ~]$ sh -x /etc/X11/xinit/xinitrc.d/zz-liveinst.duli.sh
+ '[' -b /dev/live-osimg ']'
+ test -f /home/fedora/.config/user-dirs.dirs
+ source /home/fedora/.config/user-dirs.dirs
++ XDG_DESKTOP_DIR='/home/fedora/Ãrea de Trabalho'
++ XDG_DOWNLOAD_DIR=/home/fedora/Download
++ XDG_TEMPLATES_DIR=/home/fedora/Modelos
++ XDG_PUBLICSHARE_DIR=/home/fedora/Público
++ XDG_DOCUMENTS_DIR=/home/fedora/Documentos
++ XDG_MUSIC_DIR=/home/fedora/Música
++ XDG_PICTURES_DIR=/home/fedora/Imagens
++ XDG_VIDEOS_DIR=/home/fedora/Vídeos
+ cp /usr/share/applications/liveinst.desktop '/home/fedora/Ãrea de Trabalho'
[fedora@localhost ~]$ echo $?
0


Comment 4 Jeremy Katz 2007-12-11 01:59:03 UTC
Thanks for the patch, applied to git master


Note You need to log in before you can comment on or make changes to this bug.