Bug 417541 - kdebase changes the default first day of the week upon installation
kdebase changes the default first day of the week upon installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 17:06 EST by Frank Cox
Modified: 2015-07-13 13:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 05:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Cox 2007-12-09 17:06:23 EST
Description of problem:
kalarm's first day of the week defaults to Monday.  If you subsequently install
kdebase, the default first day of the week changes to Sunday.

Version-Release number of selected component (if applicable):
kdebase-3.5.8-5.fc8

How reproducible:
Every time.

Steps to Reproduce:
1. yum install kdepim
2. kalarm
3. click on the "new alarm" icon (leftmost icon) and click on the arrow beside
"At date/time"
4. The calendar's weeks start with Monday.
5. Close kalarm
6. yum install kdebase
7. kalarm
8. click on the "new alarm" icon (leftmost icon) and click on the arrow beside
"At date/time"
9. The calendar's weeks start with Sunday.
10. Close kalarm
10. yum remove htdig xorg-x11-xdm kde-settings-kdm kdebase-libs
fedorainfinity-kdm-theme kdebase
(this removes all of the dependencies that kdebase dragged in as well)
11. kalarm
12. click on the "new alarm" icon (leftmost icon) and click on the arrow beside
"At date/time"
13. The calendar's weeks start with Monday.
  
Actual results:
Default first day of the week changes in kalarm after installing kdebase

Expected results:
The default first day of the week should not change until you run kcontrol and
change it.

Additional info:
There appears to be no other way to change the default first day of the week in
kalarm without installing kdebase and all of its dependencies.
Comment 1 Lukáš Tinkl 2007-12-10 06:49:44 EST
I need a little bit of more info:
- export | grep LANG
- export | grep LC_
- what language/country combination did you set in KDE's control center?
Comment 2 Frank Cox 2007-12-10 12:21:08 EST
$ export | grep LANG
declare -x GDM_LANG="en_US.UTF-8"
declare -x LANG="en_US.UTF-8"

$ export | grep LC_

(there was no output)

>what language/country combination did you set in KDE's control center?

I didn't change it from the default.  Under Reginaal & Accessibility -
Country/Region & Language, it says "Languages US English" and has a drop-down
list box that says "Canada" on it.

Perhaps kalarm selects the first day of the week using those settings if kdebase
is installed, but just defaults to Monday as the first day of the week if
kdebase is not installed?  If so, shouldn't that functionality be moved into
kalarm so it can at least read/determine the first day of the week without
requiring kdebase?
Comment 3 Lukáš Tinkl 2007-12-12 05:48:13 EST
Hardly a bug then, this is intended behavior. KDE apps default to Monday as 
the first day of the week but if you install KDE base _and_ your LANG envvar 
is set to US English, then the first day of the week will be Sunday of course.

Note You need to log in before you can comment on or make changes to this bug.