Bug 41809 - When attempting to compile mysql, compiler shows error then exits.
When attempting to compile mysql, compiler shows error then exits.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 09:46 EDT by Joe Y
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 09:46:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Y 2001-05-22 09:46:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Here is the version of GCC that has been installed:
  gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-81)
  version of mysql attempting to install :  3.23.36

Here is how I'm attempting to compile mysql:
./configure --prefix=/usr/local/mysql --with-low-memory --enable-shared=yes

This is what is given when attempting to compile:

loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for gawk... gawk
checking for gcc... gcc
checking whether the C compiler (gcc   ) works... yes
checking whether the C compiler (gcc   ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for c++... no
checking for g++... no
checking for gcc... gcc
checking whether the C++ compiler (gcc   ) works... no
configure: error: installation or configuration problem: C++ compiler 
cannot create executables.



How reproducible:
Always

Steps to Reproduce:
1.download, untar mysql-3.23.36.tar.gz
2.configure, using : ./configure --prefix=/usr/local/mysql --with-low-
memory --enable-shared=yes
3.
	

Actual Results:  Following output is given:

loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for gawk... gawk
checking for gcc... gcc
checking whether the C compiler (gcc   ) works... yes
checking whether the C compiler (gcc   ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for c++... no
checking for g++... no
checking for gcc... gcc
checking whether the C++ compiler (gcc   ) works... no
configure: error: installation or configuration problem: C++ compiler 
cannot create executables.

Expected Results:  I would think that it would configure mysql with the 
options i passed to it.

Additional info:

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-81)

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs 
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)

List of packages installed (custom):

Installing glibc-common.
Installing mailcap.   
Installing redhat-logos.
Installing redhat-release.
Installing setup.
Installing filesystem.
Installing basesystem.
Installing glibc.
Installing termcap. 
Installing man-pages. 
Installing compat-glibc.
Installing bdflush.
Installing chkconfig.
Installing compat-libstdc++.
Installing cracklib.
Installing db1.
Installing db2.
Installing db3.
Installing dosfstools.
Installing e2fsprogs.
Installing eject.
Installing file.
Installing gdbm.
Installing glib.
Installing hdparm.
Installing ksymoops.
Installing libtermcap.
Installing losetup.
Installing mailx.
Installing mingetty.
Installing mktemp.
Installing bash.
Installing bzip2.
Installing hotplug.
Installing libstdc++.
Installing groff.
Installing MAKEDEV.
Installing modutils.
Installing ncurses.
Installing info.
Installing cpio.
Installing diffutils.
Installing ed.
Installing fileutils.
Installing at.
Installing findutils.
Installing gawk.
Installing gettext.
Installing grep. 
Installing ash.
Installing dhcpcd.
Installing gzip.  
Installing less.      
Installing make.
Installing man.
Installing net-tools.
Installing nkf.
Installing openssl.
Installing perl.
Installing popt.
Installing logrotate.
Installing procmail.
Installing procps.
Installing psmisc.   
Installing pwdb. 
Installing raidtools.
Installing readline.
Installing ftp. 
Installing rootfiles.
Installing sed.
Installing console-tools.
Installing sendmail-cf.
Installing setserial.
Installing shadow-utils.
Installing dev.   
Installing slang.
Installing newt. 
Installing kbdconfig.
Installing ntsysv.   
Installing setuptool.
Installing slocate.
Installing sysklogd.
Installing syslinux.
Installing tar. 
Installing tcl.  
Installing tcp_wrappers.
Installing tcsh.
Installing telnet.   
Installing textutils.
Installing mount.
Installing mkinitrd.
Installing lilo.   
Installing mkbootdisk.
Installing mouseconfig.
Installing time.  
Installing tmpwatch.
Installing crontabs.  
Installing traceroute.
Installing utempter.
Installing vim-common.
Installing vim-minimal.
Installing which.  
Installing words.
Installing cracklib-dicts.
Installing pam.
Installing authconfig.
Installing cyrus-sasl.
Installing gpm.      
Installing kudzu.
Installing passwd.   
Installing sh-utils.
Installing freetype.
Installing krb5-libs.
Installing openldap.
Installing pine.
Installing sendmail.   
Installing SysVinit. 
Installing XFree86-libs.
Installing tk.    
Installing expect.
Installing zlib. 
Installing rpm.
Installing util-linux.
Installing initscripts.
Installing kernel-headers.
Installing apmd.
Installing devfsd.  
Installing ipchains.
Installing kernel.
Installing lokkit.
Installing pciutils.
Installing pump.     
Installing quota.
Installing timeconfig.
Installing vixie-cron.
Installing anacron.
Installing unzip.
Installing xinetd.
Installing wu-ftpd.
Installing cpp.
Installing tcpdump.   
Installing binutils.  
Installing dev86.   
Installing glibc-devel.
Installing gcc.
Installing ncurses-devel.
Installing patch.
Installing compat-egcs.   
Installing compat-egcs-c++.

If this is a problem with a missing package, please let me know, I'm 
installing the same packages as I have installed on previous RH Releases.  
I understand there were minor name changes, but I thought I got them all.
Comment 1 Jakub Jelinek 2001-05-22 09:48:41 EDT
You're missing at least gcc-c++ and libstdc++-devel.
Comment 2 Joe Y 2001-05-22 12:07:24 EDT
thanks, indeed, not a bug.

Note You need to log in before you can comment on or make changes to this bug.