Bug 418221 - /etc/logrotate.d/freenx broken
/etc/logrotate.d/freenx broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 10:54 EST by Need Real Name
Modified: 2007-12-10 15:44 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.1-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 15:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-10 10:54:24 EST
Description of problem:
Running logrotate gives the following error message:
   error: freenx:3 unknow unit 'B'
   error: found error in /var/log/nxserver.log, skipping

I believe the cause of the error is the following line in /etc/logrotate.d/freenx:
   size=4MB

The line should read:
   size=4M

Also, given that there is a directory labeled /var/log/nx, I am wondering why
you in the logrotate file you note /var/log/nxserver.log.
I would have thought you would have done something like:
 /var/log/nx/nxserver.log
or even,
 /var/log/nx/*.log

Version-Release number of selected component (if applicable):
0.7.1

How reproducible:
100%
Steps to Reproduce:
Run: logrotate /etc/logrotate.d/freenx
Comment 1 Jon Ciesla 2007-12-10 11:21:33 EST
> I believe the cause of the error is the following line in >
/etc/logrotate.d/freenx:
>    size=4MB

> The line should read:
>    size=4M

Correcting.

> Also, given that there is a directory labeled /var/log/nx, I am wondering why
> you in the logrotate file you note /var/log/nxserver.log.
> I would have thought you would have done something like:
>  /var/log/nx/nxserver.log
> or even,
> /var/log/nx/*.log

Not sure.  On my system, /var/log/nx is empty.  Is there content on your system?
Comment 2 Need Real Name 2007-12-10 12:31:10 EST
Yes /var/log/nx is empty for me too so I guess I was (mis)assuming that someone
had corrected that directory for freenx log files since the directory belongs to
the freenx rpm.
Also, looking in nxloadconfig, I notice that the log file is clearly set to
/var/log/nxserver so you are right in using that in the logrotate file (though
logging is turned off by default so there will typically not be a lot to rotate).

I have no idea what would dump files into /var/log/nx. Do you know what/why this
directory is created?
Comment 3 Jon Ciesla 2007-12-10 12:40:56 EST
I'll leave that question for Axel.  I have no idea.  

I'll get the fix built ASAP.
Comment 4 Jon Ciesla 2007-12-10 13:18:58 EST
Built, updates requested for F-8 and F-7 in bodhi.
Comment 5 Fedora Update System 2007-12-10 15:42:44 EST
freenx-0.7.1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-12-10 15:44:18 EST
freenx-0.7.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.