Bug 41853 - ccurve dumps core
ccurve dumps core
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-22 12:07 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 15:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-22 12:07:35 EDT
One more core file found
rpm -q xscreensaver
xscreensaver-3.29-3dbg
The trace is below:

gdb /usr/X11R6/lib/xscreensaver/ccurve core 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `ccurve -root'.
Program terminated with signal 6, Aborted.
Reading symbols from /usr/X11R6/lib/libXmu.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x401cddd1 in __kill () from /lib/libc.so.6
(gdb) bt
#0  0x401cddd1 in __kill () from /lib/libc.so.6
#1  0x401cdbaa in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x401cf352 in abort () at ../sysdeps/generic/abort.c:88
#3  0x401c77fa in __assert_fail () at assert.c:60
#4  0x8049e29 in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=1, 
    x1=1407305.2823260338, y1=6172.2285532613614, x2=-30481990500.977894, 
    y2=-9021809347.8845177, maximum_x=73182498649.482559, 
    maximum_y=54879334289.155228, minimum_x=-73162163693.459091, 
    minimum_y=-54879162468.051018, segment_count=4, points=0x805d640)
    at ccurve.c:210
#5  0x8049ece in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=2, 
    x1=1407305.2823260338, y1=1.0096977294996275e-313,
x2=169552818.38368237, 
    y2=-89476576.308005914, maximum_x=73182498649.482559, 
    maximum_y=54879334289.155228, minimum_x=-73162163693.459091, 
    minimum_y=-54879162468.051018, segment_count=4, points=0x805d640)
    at ccurve.c:217
#6  0x8049ece in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=3, 
    x1=1407305.2823260338, y1=9.0320882007392644e-314,
x2=1064665.509511695, 
    y2=1094747.6676786356, maximum_x=73182498649.482559, 
    maximum_y=54879334289.155228, minimum_x=-73162163693.459091, 
---Type <return> to continue, or q <return> to quit---
    minimum_y=-54879162468.051018, segment_count=4, points=0x805d640)
    at ccurve.c:217
#7  0x8049ece in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=4, 
    x1=0.25800000000000001, y1=4.7843417208884576e-314, 
    x2=-10.210159709192153, y2=9110.4865397789254, 
    maximum_x=73182498649.482559, maximum_y=54879334289.155228, 
    minimum_x=-73162163693.459091, minimum_y=-54879162468.051018, 
    segment_count=4, points=0x805d640) at ccurve.c:217
#8  0x8049ece in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=5, 
    x1=0.25800000000000001, y1=1.0080659263719295e-313, 
    x2=-37.962208419306336, y2=-39.041692402229465, 
    maximum_x=73182498649.482559, maximum_y=54879334289.155228, 
    minimum_x=-73162163693.459091, minimum_y=-54879162468.051018, 
    segment_count=4, points=0x805d640) at ccurve.c:217
#9  0x8049ece in self_similar_normalized (display=0x805bdc8,
pixmap=31457281, 
    context=0x805ee40, width=1024, height=768, iterations=6, 
    x1=0.25800000000000001, y1=1.008164879371082e-313,
x2=0.58499999999999996, 
    y2=-0.063, maximum_x=73182498649.482559, maximum_y=54879334289.155228, 
    minimum_x=-73162163693.459091, minimum_y=-54879162468.051018, 
    segment_count=4, points=0x805d640) at ccurve.c:217
#10 0x804a065 in self_similar (display=0x805bdc8, pixmap=31457281, 
---Type <return> to continue, or q <return> to quit---
    context=0x805ee40, width=1024, height=768, iterations=6, 
    x1=0.25800000000000001, y1=-0.069000000000000006,
x2=0.58499999999999996, 
    y2=-0.063, maximum_x=73182498649.482559, maximum_y=54879334289.155228, 
    minimum_x=-73162163693.459091, minimum_y=-54879162468.051018, 
    segment_count=768, segments=0x400) at ccurve.c:254
#11 0x804b341 in screenhack (display=0x805bdc8, window=14680072)
    at ccurve.c:755
#12 0x804c44e in main (argc=1, argv=0xbffffac4) at screenhack.c:584
#13 0x401bcf31 in __libc_start_main (main=0x804bc90 <main>, argc=2, 
    ubp_av=0xbffffac4, init=0x80491b4 <_init>, fini=0x8050d8c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffabc)
    at ../sysdeps/generic/libc-start.c:129
(gdb)
Comment 1 Need Real Name 2001-07-03 14:00:18 EDT
Another crash:

gdb /usr/X11R6/lib/xscreensaver/ccurve core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `ccurve -root'.
Program terminated with signal 6, Aborted.
Reading symbols from /usr/X11R6/lib/libXmu.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x401cddd1 in __kill () from /lib/libc.so.6
(gdb) bt
#0  0x401cddd1 in __kill () from /lib/libc.so.6
#1  0x401cdbaa in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x401cf352 in abort () at ../sysdeps/generic/abort.c:88
#3  0x401c77fa in __assert_fail () at assert.c:60
#4  0x8049e29 in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=1, 
    x1=-6343422862.2619228, y1=46420041838.699699, x2=11293258858.339516, 
    y2=117507362707.18774, maximum_x=762116289035.77441, 
    maximum_y=517257931351.72546, minimum_x=-700926022707.73596, 
    minimum_y=-580023802455.90735, segment_count=4, points=0x805ec78)
    at ccurve.c:210
#5  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=2, x1=0.187, 
    y1=6.9132274519468506e-314, x2=-89078095.504058778, y2=8595089.8140953444, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#6  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=3, x1=0.187, 
    y1=1.0092601238971567e-313, x2=-55099.644270416204, 
    y2=-161816.50872357676, maximum_x=762116289035.77441, 
    maximum_y=517257931351.72546, minimum_x=-700926022707.73596, 
    minimum_y=-580023802455.90735, segment_count=4, points=0x805ec78)
---Type <return> to continue, or q <return> to quit---
    at ccurve.c:217
#7  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=4, x1=0.187, 
    y1=1.00870859876255e-313, x2=276.79444153640947, y2=-173.906103661332, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#8  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=5, x1=0.187, 
    y1=9.0221506508003016e-314, x2=0.63100000000000001, y2=0.027, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#9  0x804a065 in self_similar (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=5, x1=0.187, 
    y1=-0.41100000000000003, x2=0.63100000000000001, y2=0.027, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=768, segments=0x400) at ccurve.c:254
#10 0x804b341 in screenhack (display=0x805bdc8, window=12582918)
    at ccurve.c:755
#11 0x804c44e in main (argc=1, argv=0xbffffac4) at screenhack.c:584
#12 0x401bcf31 in __libc_start_main (main=0x804bc90 <main>, argc=2, 
---Type <return> to continue, or q <return> to quit---
    ubp_av=0xbffffac4, init=0x80491b4 <_init>, fini=0x8050d8c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffabc)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
Comment 2 Need Real Name 2001-07-03 14:07:27 EDT
Another crash:

gdb /usr/X11R6/lib/xscreensaver/ccurve core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `ccurve -root'.
Program terminated with signal 6, Aborted.
Reading symbols from /usr/X11R6/lib/libXmu.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x401cddd1 in __kill () from /lib/libc.so.6
(gdb) bt
#0  0x401cddd1 in __kill () from /lib/libc.so.6
#1  0x401cdbaa in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x401cf352 in abort () at ../sysdeps/generic/abort.c:88
#3  0x401c77fa in __assert_fail () at assert.c:60
#4  0x8049e29 in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=1, 
    x1=-6343422862.2619228, y1=46420041838.699699, x2=11293258858.339516, 
    y2=117507362707.18774, maximum_x=762116289035.77441, 
    maximum_y=517257931351.72546, minimum_x=-700926022707.73596, 
    minimum_y=-580023802455.90735, segment_count=4, points=0x805ec78)
    at ccurve.c:210
#5  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=2, x1=0.187, 
    y1=6.9132274519468506e-314, x2=-89078095.504058778, y2=8595089.8140953444, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#6  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=3, x1=0.187, 
    y1=1.0092601238971567e-313, x2=-55099.644270416204, 
    y2=-161816.50872357676, maximum_x=762116289035.77441, 
    maximum_y=517257931351.72546, minimum_x=-700926022707.73596, 
    minimum_y=-580023802455.90735, segment_count=4, points=0x805ec78)
---Type <return> to continue, or q <return> to quit---
    at ccurve.c:217
#7  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=4, x1=0.187, 
    y1=1.00870859876255e-313, x2=276.79444153640947, y2=-173.906103661332, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#8  0x8049ece in self_similar_normalized (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=5, x1=0.187, 
    y1=9.0221506508003016e-314, x2=0.63100000000000001, y2=0.027, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=4, points=0x805ec78) at ccurve.c:217
#9  0x804a065 in self_similar (display=0x805bdc8, pixmap=37748737, 
    context=0x805ee40, width=1024, height=768, iterations=5, x1=0.187, 
    y1=-0.41100000000000003, x2=0.63100000000000001, y2=0.027, 
    maximum_x=762116289035.77441, maximum_y=517257931351.72546, 
    minimum_x=-700926022707.73596, minimum_y=-580023802455.90735, 
    segment_count=768, segments=0x400) at ccurve.c:254
#10 0x804b341 in screenhack (display=0x805bdc8, window=12582918)
    at ccurve.c:755
#11 0x804c44e in main (argc=1, argv=0xbffffac4) at screenhack.c:584
#12 0x401bcf31 in __libc_start_main (main=0x804bc90 <main>, argc=2, 
---Type <return> to continue, or q <return> to quit---
    ubp_av=0xbffffac4, init=0x80491b4 <_init>, fini=0x8050d8c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffabc)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
Comment 3 Jamie Zawinski 2002-07-27 02:33:18 EDT
How reproducible is this? I've tried a few things here, and I can't reproduce it
(except by plugging in your values, which doesn't tell me much.)  I also don't
really understand the code, or what those assertions are trying to protect
against...
Comment 4 Need Real Name 2002-08-01 16:36:22 EDT
>How reproducible is this

The only way how I get such core dumps - is to leave the screensaver running
and then periodically check for core file in user home directory.
With ccurve program from xscreensaver-3.29-3dbg under RedHat 7.0
this happens at least 2 times a month.
Comment 5 Ray Strode [halfline] 2004-11-10 15:05:48 EST
Hi,

This bug is quite old now.  Given the lack of activity on this report and the
likelihood that this bug has already been fixed, I am going to close it.  If you
encounter the problem discussed in this report with Fedora Core 3 or a recent
version of xscreensaver, feel free to reopen.

Thanks

Note You need to log in before you can comment on or make changes to this bug.