Bug 41858 - Crackling sound/hung applications when using via onboard audio (via82cxxx_audio)
Summary: Crackling sound/hung applications when using via onboard audio (via82cxxx_audio)
Status: CLOSED DUPLICATE of bug 38215
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-22 16:49 UTC by Jeremy Sanders
Modified: 2007-04-18 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Sanders 2001-05-22 16:49:15 UTC
Description of Problem:
Using the via82cxxx_audio driver and ac97_codec (as detected by sndconfig),
the sound on my machine barely works. The sample played by sndconfig is
perfect, but sounds played from other apps is awful.

mpg123: very crackly sound (straight to audio device)
xmms: application plays (to esd) in short segments. The app pauses whilst
it is played, then it seems to fill up the buffer (normally), then pause again.

play: Works fine! Even on the audio (.au) file produced from one of the
other programs. Even under load.

esd: gnome apps crackle when producing sound.

I also get the following log messages:

Via 686a audio driver 1.1.14b
PCI: Assigned IRQ 11 for device 00:07.5
ac97_codec: AC97 Audio codec, id: 0x4943:0x4511 (ICE1232)
via82cxxx: board #1 at 0xDC00, IRQ 11
[...]
via_audio: ignoring drain playback error -512
via_audio: ignoring drain playback error -512
via_audio: ignoring drain playback error -512
via_audio: ignoring drain playback error -512
via_audio: ignoring drain playback error -512
[...]

How Reproducible:
Always


Steps to Reproduce:
1. Load mp3 into xmms (or mpg123)
2. Play
3. 

Actual Results:


Expected Results:


Additional Information:
The onboard audio worked fine using RH 6.1 and a custom 2.2.19 kernel.

cat /proc/pci
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 3).
      Prefetchable 32 bit memory at 0xd0000000 [0xd3ffffff].
  Bus  0, device   1, function  0:
    PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP] (rev 0).
      Master Capable.  No bursts.  Min Gnt=12.
  Bus  0, device   7, function  0:
    ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 64).
  Bus  0, device   7, function  1:
    IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 6).
      Master Capable.  Latency=32.  
      I/O at 0xd000 [0xd00f].
  Bus  0, device   7, function  2:
    USB Controller: VIA Technologies, Inc. UHCI USB (rev 22).
      IRQ 5.
      Master Capable.  Latency=32.  
      I/O at 0xd400 [0xd41f].
  Bus  0, device   7, function  3:
    USB Controller: VIA Technologies, Inc. UHCI USB (#2) (rev 22).
      IRQ 5.
      Master Capable.  Latency=32.  
      I/O at 0xd800 [0xd81f].
  Bus  0, device   7, function  4:
    Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 64).
      IRQ 9.
  Bus  0, device   7, function  5:
    Multimedia audio controller: VIA Technologies, Inc. AC97 Audio
Controller (rev 80).
      IRQ 11.
      I/O at 0xdc00 [0xdcff].
      I/O at 0xe000 [0xe003].
      I/O at 0xe400 [0xe403].
  Bus  0, device  12, function  0:
    Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 12).
      IRQ 10.
      Master Capable.  Latency=32.  Min Gnt=8.Max Lat=56.
      Non-prefetchable 32 bit memory at 0xda020000 [0xda020fff].
      I/O at 0xec00 [0xec3f].
      Non-prefetchable 32 bit memory at 0xda000000 [0xda01ffff].
  Bus  1, device   0, function  0:
    VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 130).
      IRQ 5.
      Master Capable.  Latency=32.  Min Gnt=16.Max Lat=32.
      Prefetchable 32 bit memory at 0xd4000000 [0xd5ffffff].
      Non-prefetchable 32 bit memory at 0xd6000000 [0xd6003fff].
      Non-prefetchable 32 bit memory at 0xd7000000 [0xd77fffff].

xpc1:~> cat /proc/cpuinfo 
processor
: 0
vendor_id
: AuthenticAMD
cpu family	: 6
model
	: 4
model name	: AMD Athlon(tm) Processor
stepping
: 2
cpu MHz		: 1299.401
cache size	: 256 KB
fdiv_bug
: no
hlt_bug
	: no
f00f_bug
: no
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 1
wp
	: yes
flags
	: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx
fxsr syscall mmxext 3dnowext 3dnow
bogomips
: 2588.67

Comment 1 Arjan van de Ven 2001-05-22 17:38:56 UTC
The kernel in rawhide has a newer version of the via sounddriver. Would you
be willing to test that ? (and as a bonus, there is an athlon kernel there too,
you just have to use rpm -i --ignorearch kernel-2.4.3-5.athlon.rpm)

Comment 2 Jeremy Sanders 2001-05-23 12:10:43 UTC
Using the rawhide kernel kernel-2.4.3-5.athlon.rpm doesn't improve anything :-(

Any suggestions? I suppose I could build a Linus kernel...


Comment 3 Jeremy Sanders 2001-05-23 13:33:13 UTC
Hmmm - the bug is still present on a Linus 2.4.4 kernel, built from scratch.


Comment 4 Need Real Name 2001-06-14 11:56:14 UTC
I am getting crackling quite offen too, and sometimes no sound at all on some 
apps / games.
My system is a Dual Processor P3 700E on a VIA motherboard using the same sound 
chip (SMP kernel).

Comment 5 Alan Cox 2003-06-06 12:53:24 UTC

*** This bug has been marked as a duplicate of 38215 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:48:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.