Bug 419071 - doc license (OPL) is not using free clauses
Summary: doc license (OPL) is not using free clauses
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL: /usr/share/doc/system-config-kickstar...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-11 01:17 UTC by Karsten Wade
Modified: 2007-12-11 18:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 18:12:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated legal notice file (3.32 KB, text/html)
2007-12-11 17:54 UTC, Karsten Wade
no flags Details

Description Karsten Wade 2007-12-11 01:17:38 UTC
In Fedora 7 and 8 (and earlier) versions, system-config-kickstart ships with
documentation that is under the Open Publication License (OPL) 1.0.  This
license usage calls out two optional clauses of the OPL that make the content
not freely modifiable or distributable.  This usage is a remnant from the Red
Hat ownership of the package when all docs were under that style of OPL; this is
no longer the case, and Fedora uses the OPL *only* without the optional clauses.

The file is:

/usr/share/doc/system-config-kickstart-<version>/html/legalnotice.html

Below are two texts.  (A) shows the license as how it currently appears in the
package.  (B) shows how it should appear.  We may also want to update the
copyright notice, although if the content hasn't changed at all since then,
perhaps not.

BTW, one benefit of this change is that Fedora Docs can then use the content for
the Fedora Administration Guide, and help maintain the upstream version so we
can draw from it downstream into our doc.

You may also want to update the entire legalnotice file (and
copyright), since we no longer are required to call out all those
individual trademarks in that way.  Here is an example of the
legalnotice is constructed now:

http://docs.fedoraproject.org/release-notes/f8/en_US/sn-legalnotice.html

If you want to attach a copy of the XML file to this bug report, I can do the
update and submit a patch.

(A)  
Copyright © 2003 by Red Hat, Inc. This material may be distributed only
subject to the terms and conditions set forth in the Open Publication License,
V1.0 or later (the latest version is presently available at
http://www.opencontent.org/openpub/).

Distribution of substantively modified versions of this document is prohibited
without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book
form for commercial purposes is prohibited unless prior permission is obtained
from the copyright holder.

(B)
Copyright © 2003 by Red Hat, Inc. This material may be distributed only subject
to the terms and conditions set forth in the Open Publication License, V1.0 or
later (the latest version is presently available at
http://www.opencontent.org/openpub/).

Comment 1 Chris Lumens 2007-12-11 15:43:18 UTC
All the files in the doc subdirectory look like they were generated from
something, but I have no idea what and I don't have the source files either. 
The docs haven't been seriously updated in years so we should decide whether we
want to make a real effort to update them and keep them up to date, or to just
drop them.  Whichever we want to do will decide what I do with this bug report.

Feel free to submit a totally new legalnotice.html file.

Comment 2 Karsten Wade 2007-12-11 17:50:36 UTC
Those files would have originally been generated from DocBook SGML (most likely,
considering the age.)  The original source files may be in Red Hat Docs CVS.  Do
you just have them as built HTML?

I'll attach an updated legalnotice.html file just so we can fix the immediate
license situation.  Let's keep the content where it is and I'll bring the
question to Fedora Docs if we want to update and help maintain it; this will
depend on if we see there being a future in downstream usage in our other docs.

Comment 3 Karsten Wade 2007-12-11 17:54:10 UTC
Created attachment 284371 [details]
updated legal notice file

Comment 4 Chris Lumens 2007-12-11 18:12:52 UTC
That is correct.  I only have the built HTML files.  I guess it's possible they
exist somewhere back in the mists of time, but I don't see anything in the
source control logs that indicates what could have happened.

I've applied your new license file so I'm going to close out this bug.  Let's
carry the rest of this discussion over to email as I don't think it lends itself
to bugzilla too well.


Note You need to log in before you can comment on or make changes to this bug.