Bug 42032 - (E100 APM)apm (resume) problem with eepro100 NIC
(E100 APM)apm (resume) problem with eepro100 NIC
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-23 16:09 EDT by Inger Karin Haarbye
Modified: 2013-07-02 22:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:32:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2001-05-23 16:09:30 EDT
Description of Problem:

After suspend on Dell Inspiron 8000 with buildt in minipci NIC 
(Actiontec) - the NIC doesn't work.
I get lots of these errors all the time: 
wait_for_cmd_done timeout!

How Reproducible:

every time.

Steps to Reproduce:
1. apm -s or suspend in other ways (close the laptop).
2. 
3. 

Additional Information:

Kernel-2.4.2-2 in Seawolf
Comment 1 Arjan van de Ven 2001-05-24 04:28:27 EDT
Some people report that if you change from the "eepro100" to the "e100" module,
suspend works. This change needs to be made in /etc/modules.conf

Could you try this ?
Comment 2 Inger Karin Haarbye 2001-05-25 10:13:58 EDT
No, this didn't work. I tried it before with one of the betas, gave same 
results as eepro100. 
Now I tried it in Seawolf too - I did not get the same error message, but the 
network still doesn't come up after suspend.

/var/log/messages: (free translated from norwegian:)
SIOCSIFFLAGS: resource temporary unavailable
SIOCADDRT: Network is down
SIOCADDRT: Network is noe available.

(Seems like irq-problem maybe - since the driver now has got io-adress, not 
irq)
Comment 3 Rob Gerth 2002-01-02 23:47:21 EST
I'm experiencing a similar (same?) problem on a T21 Thinkpad. My work around
is to compile eepro100 as a module and to explicitly reload before a network
restart in apmcontinue:
      [ "$NET_RESTART" = "yes" ] && {
           /etc/rc.d/init.d/network stop
           /sbin/rmmod eepro100
           /sbin/modprobe eepro100
           /etc/rc.d/init.d.network start
       }
Comment 4 Jeff Garzik 2004-03-03 00:53:47 EST
Does e100 driver have the same problem?  We are deprecating eepro100
in favor of e100.
Comment 5 Jeff Garzik 2004-03-03 03:32:46 EST
Nevermind, closing bug as ancient.

Note You need to log in before you can comment on or make changes to this bug.