Bug 420591 - kcron silent option is broken
kcron silent option is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdeadmin (Show other bugs)
5.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 16:26 EST by Jeff Bastian
Modified: 2013-04-15 04:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: kdeadmin-3_5_4-4_el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, when creating a new cron job in KCron with the silent option enabled, KCron failed and displayed the following error message: An error occurred while updating crontab. This update corrects the problem so that KCron now works with the silent option enabled, as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 09:04:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upstream patch to remove silent option from kcron (3.93 KB, patch)
2007-12-11 17:01 EST, Jeff Bastian
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 85425 None None None Never

  None (edit)
Description Jeff Bastian 2007-12-11 16:26:38 EST
Description of problem:
When creating a new cron job with kcron, there's a checkbox to make the job
silent.  If you enable the silent option, kcron fails with a generic error:
  An error occurred while updating crontab.

Launch kcron from a terminal and this error appears when saving the job:
  "/tmp/kde-user/kcrondR2FDb.tmp":2: bad minute
  errors in crontab file, can't install.

The problem is that kcron tries to insert a '-' before the minutes field to make
the job silent (apparently this is an extension for some flavors of cron). 
I.E., the line it creates looks like
  -1 2 3 4 5 /usr/bin/something

This has been reported upstream and the silent option has been removed.
  http://bugs.kde.org/show_bug.cgi?id=85425


Version-Release number of selected component (if applicable):
  kdeadmin-3.5.4-2.fc6

How reproducible:
Everytime

Steps to Reproduce:
1. Launch kcron
2. Create a new job and enable the Silent check box
3. Save
  
Actual results:
An error occurred while updating crontab.

Expected results:
It should work, but the upstream choice was to remove the option.

Additional info:
Comment 1 Jeff Bastian 2007-12-11 17:01:03 EST
Created attachment 284691 [details]
upstream patch to remove silent option from kcron

I've tested this patch on RHEL 5.1 and verified it removes the Silent option.

It also removes any offending leading '-' characters from legacy silent jobs.
Comment 3 Ngo Than 2008-01-18 05:20:57 EST
it's late for RHEL-5.2 update. devel+ for RHEL-5.3
Comment 4 Phil Knirsch 2008-04-29 11:32:48 EDT
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil
Comment 5 Thomas Woerner 2008-07-14 15:16:21 EDT
The maintainter will be back on Monday. Querying exception flag for now.
Comment 6 Ngo Than 2008-07-22 11:43:46 EDT
+devel for RHEL-5.4
Comment 7 RHEL Product and Program Management 2009-03-26 12:52:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 RHEL Product and Program Management 2010-08-09 14:33:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-01-11 15:58:47 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2011-01-11 17:40:42 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 18 Vladimir Benes 2011-08-25 11:45:08 EDT
reproducer in comment #0
-> qa_ack+
Comment 22 Petr Kovar 2011-09-06 10:32:02 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, when creating a new cron job in KCron with the silent option enabled, KCron failed and displayed the following error message: 

    An error occurred while updating crontab.

This update corrects the problem so that KCron now works with the silent option enabled, as expected.
Comment 23 errata-xmlrpc 2011-09-07 09:04:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1279.html

Note You need to log in before you can comment on or make changes to this bug.