This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 421121 - rawhide installer lists non-existent ethernet interfaces
rawhide installer lists non-existent ethernet interfaces
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 04:42 EST by Olof Johansson
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 16:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olof Johansson 2007-12-12 04:42:54 EST
Description of problem:

The interfaces in the dialog asking for network configuration have the wrong
information listed next to the interface numbers.

Version-Release number of selected component (if applicable):
Rawhide as of 20071211 (anaconda 11.4.0.8)

How reproducible:

Steps to Reproduce:
1.Boot netboot install image on PA Semi Electra system (PPC)
2.Choose one of the network sources
3.See interface information listed in wrong order
  
Actual results:
                  +----------+ Networking Device +----------+                   
                  |                                         |                   
                  | You have multiple network devices on    |                   
                  | this system. Which would you like to    |                   
                  | install through?                        |                   
                  |                                         |                   
                  | eth0 - PA Semi, Inc Unknown device a005 |                   
                  | eth1 - PA Semi, Inc Unknown device a006 |                   
                  | eth2 - PA Semi, Inc Unknown device a006 |                   
                  | eth3 - PA Semi, Inc Unknown device a005 |                   
                  | eth4 - PA Semi, Inc Unknown device a005 |                   
                  | eth5 - PA Semi, Inc Unknown device a005 |                   
                  |                                         |                   
                  |      +----+             +------+        |                   
                  |      | OK |             | Back |        |                   
                  |      +----+             +------+        |                   
                  |                                         |                   
                  |                                         |                   
                  +-----------------------------------------+  

Expected results:
eth0: PCI ID a005
eth1: PCI ID a005
eth2: PCI ID a005

Only eth0, eth1 and eth2 are available on this system, the other interfaces do
not configure since firmware reported them as not available (i.e. the SoC has
them, but they're not connected to anything on the boards of this system). They
still show up on PCI ID listings, but not in ifconfig -a output, as expected.

Additional info:
Comment 1 David Woodhouse 2007-12-12 10:05:46 EST
This is because the installer hasn't tried loading the drivers yet -- it's
_only_ looked at the PCI ID listings and compared with the available drivers.

One possible answer would be to remove the MODULE_DEVICE_TABLE(pci, ...) from
the driver, and replace it with an OpenFirmware match table so that only those
devices listed in the driver-tree will get noticed.

We don't even need to change the way the driver actually works -- it could still
register a PCI driver with the core; it's just the MODULE_DEVICE_TABLE which
affects the automatic loading of the module.

Alternatively, I think we could just wait for the upcoming rewrite of kudzu,
which probes hardware. It's going to just use udev and normal hotplug behaviour,
and thus should get it right anyway.
Comment 2 Olof Johansson 2007-12-12 17:47:51 EST
(In reply to comment #1)
> This is because the installer hasn't tried loading the drivers yet -- it's
> _only_ looked at the PCI ID listings and compared with the available drivers.

I don't mind the extra devices being listed as much as the order being wrong.

Hardware has devices the following devices (and assignments by default in linux):

device 14 function 0: GMAC (0xa005) (unused)
device 14 function 1: GMAC (0xa005) (eth0)
device 14 function 2: GMAC (0xa005) (eth1)
device 14 function 3: GMAC (0xa005) (eth2)
device 15 function 0: XAUI (0xa006) (unused)
device 15 function 1: XAUI (0xa006) (unused)

But 0xa006 is shown for the 2nd and 3rd interface, which is somewhat confusing.
I don't remember seeing this from the slightly older rawhide installer, but I
might be wrong.

> Alternatively, I think we could just wait for the upcoming rewrite of kudzu,
> which probes hardware. It's going to just use udev and normal hotplug behaviour,
> and thus should get it right anyway.

Sounds good to me. Is that targetted for F9, or later version?
Comment 3 Bill Nottingham 2007-12-18 20:52:38 EST
Targeted for F9. Will hopefully land before the alpha.
Comment 4 Bill Nottingham 2008-02-26 16:12:09 EST
This is 'fixed' now, as anaconda is no longer using kudzu.

Note You need to log in before you can comment on or make changes to this bug.