Bug 421381 - 3D game makes Xorg crash
3D game makes Xorg crash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 08:29 EST by Ronald
Modified: 2007-12-12 10:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 09:37:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald 2007-12-12 08:29:39 EST
Description of problem:

When starting urban terror (a game at www.urbanterror.net) the server crashes.

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80cdfb1]
1: [0xb7f46420]

Fatal server error:
Caught signal 11.  Server aborting

I'm using nvidia 100.14.19.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.3.0.0-36.fc8

How reproducible:

Update to the above version of Xorg and then try to play the game...

Steps to Reproduce:
1. Install Fedora
2. Update Fedora
3. Play UrbanTerror
  
Actual results:

Xorg-server crashes

Expected results:

Game that works.

Additional info:

I think that Xorg is the cause because I did not change anything to the box
except for the updates. These were the updates:

dec 11 20:34:39 Updated: libsepol - 2.0.15-1.fc8.i386
dec 11 20:34:39 Updated: libsemanage - 2.0.12-2.fc8.i386
dec 11 20:34:41 Updated: samba-common - 3.0.28-0.fc8.i386
dec 11 20:34:43 Updated: policycoreutils - 2.0.32-2.fc8.i386
dec 11 20:34:43 Updated: cyrus-sasl-lib - 2.1.22-8.fc8.i386
dec 11 20:34:43 Updated: cyrus-sasl-plain - 2.1.22-8.fc8.i386
dec 11 20:34:44 Updated: samba-client - 3.0.28-0.fc8.i386
dec 11 20:34:46 Updated: samba - 3.0.28-0.fc8.i386
dec 11 20:34:47 Updated: xorg-x11-server-Xorg - 1.3.0.0-36.fc8.i386
dec 11 20:34:48 Updated: selinux-policy - 3.0.8-64.fc8.noarch
dec 11 20:35:24 Updated: selinux-policy-targeted - 3.0.8-64.fc8.noarch
dec 12 14:13:41 Updated: yum - 3.2.8-2.fc8.noarch

I assume that Xorg is the cause since it's the only program related to video etc...
Comment 1 Ronald 2007-12-12 08:30:13 EST
Not that the game did work in previous versions of X!
Comment 2 Ronald 2007-12-12 08:30:48 EST
I meant:

The game did work in previous versions of X!
Comment 3 Ronald 2007-12-12 09:37:30 EST
Never mind, I just noticed that there was a new beta driver available from
nvidia. I updated to that version and everything works again.
Comment 4 Matěj Cepl 2007-12-12 10:25:11 EST
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.