Bug 421581 - Problem with nfs mounts of bind mounted directories
Problem with nfs mounts of bind mounted directories
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 09:32 EST by Terry Barnaby
Modified: 2014-06-18 03:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 15:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Barnaby 2007-12-12 09:32:57 EST
On my server I have a hard disk partition mounted on /data. In this partition I
have a directory /home with all of the users files.
The /data/home directory is mounted using the --bind option to /home.

On a client system I can NFS mount /home and /data from the server.
However the clients /data directory ends up being actually a mount
of /home !
This worked fine under FC6.

There is a kernel message on the server:
mountd[4612]: /home and /data have same filehandle for *.kingnet, using first

This seems like a bug to me ... 

Kernel: 2.6.23.8-63.fc8

How reproducible:
Solid fault.

Steps to Reproduce:
1. Mount using --bind a partitions subdirectory to somewhere.
2. Export both mount points.
3. On a client mount both mount points.
Comment 1 Jeff Layton 2008-01-21 07:28:26 EST
> There is a kernel message on the server:
> mountd[4612]: /home and /data have same filehandle for *.kingnet, using first

This is because the "device" portion of the filehandle is coming from the same
info on this filesystem. If you apply different "fsid=" options to both exports,
does that work around this problem?

i.e.: give /home "fsid=1", and /data "fsid=2"

see exports(5) for more info on the fsid= option...

Comment 2 Jeff Layton 2008-04-23 15:46:37 EDT
No response in several months. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.