Bug 421741 - Wine starts at wrong level
Wine starts at wrong level
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 10:09 EST by Nigel Horne
Modified: 2007-12-12 10:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 10:22:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2007-12-12 10:09:02 EST
Description of problem:
Wine is enabled at levels 2 3 4 5, but it makes no sense to run programs under
wine unless X is up, so it should only be enabled at level 5.


Version-Release number of selected component (if applicable):
wine-0.9.49-1.fc8

How reproducible:
100%


Steps to Reproduce:
1. Boot to init level 3
2. /sbin/service wine status
3.
  
Actual results:
It's enabled

Expected results:
It shouldn't be

Additional info:
Comment 1 Andreas Bierfert 2007-12-12 10:22:32 EST
Quoting from /etc/inittab:

#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11

All these are _valid_ runlevels for starting X and applications that need X
(actually one could argue if 1 is also valid). Another point: Wine in general is
not restricted to be used with X. Despite that this setup is ok there is no
speed impact because it is not wine that gets started but just the binary
handler is inserted into the kernel.

Note You need to log in before you can comment on or make changes to this bug.