Bug 422081 - fails to connect to SSL server
fails to connect to SSL server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 12:27 EST by Jeremy Katz
Modified: 2007-12-13 12:19 EST (History)
1 user (show)

See Also:
Fixed In Version: openssl-0.9.8g-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 12:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-12-12 12:27:19 EST
Since updating to openssl-0.9.8, xchat-gnome can't connect to SSL servers anymore.

  Connection failed. Error: (336151568) error:14094410:SSL 
  routines:SSL3_READ_BYTES:sslv3 alert handshake failure
Comment 1 Tomas Mraz 2007-12-12 13:45:16 EST
Can openssl s_client connect to the servers without problems?
Comment 2 Jeremy Katz 2007-12-12 13:57:51 EST
Yep
Comment 3 Tomas Mraz 2007-12-12 16:18:58 EST
And what about openssl s_client -ssl3 ?
Comment 4 Jeremy Katz 2007-12-12 16:26:52 EST
Fails
CONNECTED(00000003)
12702:error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake
failure:s3_pkt.c:1053:SSL alert number 40
12702:error:1409E0E5:SSL routines:SSL3_WRITE_BYTES:ssl handshake
failure:s3_pkt.c:530:
Comment 5 Jeremy Katz 2007-12-12 16:42:28 EST
Public server that exhibits the behavior is mozilla's -- irc.mozilla.org:6697
Comment 6 Tomas Mraz 2007-12-13 12:19:59 EST
Caused by sending tls ext in sslv3 client hello. The ssl server should tolerate
and ignore this but some apparently do not.

Note You need to log in before you can comment on or make changes to this bug.