Bug 422111 - cannot connect to NFS server when allowing service NFS4 in firewall
cannot connect to NFS server when allowing service NFS4 in firewall
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 12:33 EST by Dr. Firas Swidan
Modified: 2008-01-08 06:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 06:05:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. Firas Swidan 2007-12-12 12:33:09 EST
Description of problem:

No connection is possible to the NFS server when allowing service NFS4 in
system-config-firewall. The result of trying to mount a directory is:

# mount x.x.x.x:/this /here 
mount: mount to NFS server 'x.x.x.x' failed: System Error: No route to host.

disabling firewall and retrying to mount works fine.


Version-Release number of selected component (if applicable):
1.0.11.1.fc8

How reproducible:
Enable firewall, and allow service NFS4 through system-config-firewall

Steps to Reproduce:
1. system-config-firewall
2. enable firewall
3. allow service NFS4
  
Actual results:

mounting NFS shared directory fails.

Expected results:

mounting NFS shared directory succeeds.

Additional info:
Comment 1 Thomas Woerner 2007-12-12 13:02:59 EST
Are you using NFS4 on both sides?
Comment 2 Dr. Firas Swidan 2007-12-12 13:48:20 EST
Good point. I should have mount -t nfs4. Thanks.
Comment 3 Thomas Woerner 2008-01-08 06:05:45 EST
Closing as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.