Bug 42218 - RH 7.1 installation problems!
RH 7.1 installation problems!
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 17:20 EDT by shahmil_m
Modified: 2007-03-26 23:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 12:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shahmil_m 2001-05-24 17:20:34 EDT
Description of Problem:
I am trying to install RH 7.1 on a supermicro superserver 6010H 370DER 
Motherboard,P111 866,Adpatec 3200S 64 bit PCI RAID controler(raid level 1)
Apaptec aic-7899 dual channel SCSI controller
I try booting from Cd and i reach the stage where i click on the custom 
installation icon and i get an error "no valid devices were found on which 
to create new filesystems" and when i click ok the system reboots
I tried installing some of the drivers from Doug's aic-7xxx page but to no 
avail.Could some one please answer back on this forum or my email.




How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Brent Fox 2001-05-24 17:48:19 EDT
Try booting with 'linux ide=nodma'.  Does that help?
Comment 2 shahmil_m 2001-05-24 19:44:04 EDT
I did try linux ide=nodma and it did not seem to help
Comment 3 shahmil_m 2001-05-25 09:30:54 EDT
I think there is a problem with the dpt_i2o.o driver and i need to install 
one.I am trying to find a driver for the same kernel(2.2.16) from Suse 
distribution.Not too sure if it si the problem!
Comment 4 Brent Fox 2001-05-31 13:50:15 EDT
You might try using 'linux expert noprobe' and skip the devices that are giving
you trouble.  Let me know if that helps.
Comment 5 shahmil_m 2001-06-05 14:50:50 EDT
i tried the above linux expert noprobe and i get the same error..........
The error yet continues to be to devices found to mount files system
check hardware.........
I think i have to get a  dpt_i2o driver
if you could send me one i tink i shold have no problems
Comment 6 Alex Yu 2001-06-08 01:40:22 EDT
I built this disk driver image against Adaptec's March 28th I2O 2.2 driver 
patch for kernel-2.4.2.  This disk driver should work with both Red Hat 7.0 and 
7.1 Installers.  This driver disk supports Adaptec SCSI RAID 2100S, 3200S, and 
3400S.  I don't work for Adaptec ;)  I have 3200S and I spent one full day to 
get the driver working with kernel 2.4.2.  Actually, I have spent 95% of the 
time on 2.2.19, but it always failed on me.  2.4.2 works perfectly.  

You can obtain the image file at this URL:

http://www.angelfire.com/art/ayu168/

Installation:

1. Create the driver disk using the dd command (on a Linux machine) or the 
rawrite utility.
2. When the Red Hat welcome screen appears, type expert at the boot prompt.
3. When prompted, insert the driver disk you created in Step 1 and select OK.
4. Red Hat 7.1 Installer should auto detect the RAID SCSI controller card.  (If 
you are installing Red Hat 7.0, scroll down and select the Adaptec driver.  The 
system informs you that it has found the Adaptec I 2 O RAID Host Adapter.)
5. Have fun!

***Please report if it works...***

Note: Just install 7.1 ;)  You don't want to install 7.0 (ships kernel 
2.2.16).  No matter what I tried, initrd always failed on kernel 2.2.19.

Note 2: Only 2.4.2-2BOOT driver is built against arch i386.  2.4.2-2, 2.4.2-
2smp, and 2.4.2-2ent are built against arch i686.
Comment 7 shahmil_m 2001-06-08 10:25:06 EDT
Dude Thanks a million...it works!!!!!!!!!!!!!!!!!!!!!!!!!!!
Thanks once again!
Comment 8 Brent Fox 2001-06-11 12:16:57 EDT
I'm changing the component to the kernel so they can have a look at this driver.
Comment 9 Brent Fox 2003-05-25 12:05:28 EDT
I'm going to close this as 'currentrelease' since this report is so old now.  I
you're still having trouble with RHL 8 or 9, please open a new bug report. 
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.