Bug 42221 - kernel: scsi : aborting command due to timeout
kernel: scsi : aborting command due to timeout
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 19:01 EDT by Luis Gerardo de la Fraga
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-25 04:04:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Gerardo de la Fraga 2001-05-24 19:01:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)

Description of problem:
Can't burn CD's. Kernel send aborting commands due a
command timeout and lots of resetings to the SCSI bus



How reproducible:
Always

Steps to Reproduce:
1.Introduce a CD to be burned In the CD-writer 
2.Send a full data (>400M) file to the CD
3.
	

Actual Results:  I have a machine with 1 cdrom and 1 cd-writer:
In /var/log/dmesg:
hdb: CRD-8480M, ATAPI CDROM drive
hdc: HP CD-Writer+ 7200, ATAPI CDROM drive

when CD is inserted on CD-writer, kernel said (in /var/log/messages)
.
.
.
May 24 15:51:23 sirius kernel: cdrom: This disc doesn't have any tracks I
recognize!
May 24 15:51:37 sirius last message repeated 8 times
May 24 15:51:46 sirius kernel: cdrom: This disc doesn't have any tracks I
recognize!
May 24 15:52:18 sirius last message repeated 17 times
May 24 15:52:24 sirius last message repeated 3 times
May 24 15:52:25 sirius modprobe: modprobe: Can't locate module
char-major-97
May 24 15:52:25 sirius last message repeated 3 times
May 24 15:52:26 sirius kernel: cdrom: This disc doesn't have any tracks I
recognize!
May 24 15:52:58 sirius last message repeated 16 times
May 24 15:53:59 sirius last message repeated 30 times
May 24 15:56:07 sirius last message repeated 13 times
May 24 15:56:46 sirius last message repeated 18 times
May 24 15:56:50 sirius kernel: Device not ready.  Make sure there is a disc
in the drive.
May 24 15:57:21 sirius last message repeated 16 times
May 24 15:58:23 sirius last message repeated 31 times
.
.
.
And it produces these last messages many times.
Before the burning process has finished, kenel said (in /var/log/messages
again):

May 24 16:18:46 sirius last message repeated 31 times
May 24 16:19:47 sirius last message repeated 30 times
May 24 16:19:59 sirius last message repeated 6 times
May 24 16:20:00 sirius CROND[1067]: (root) CMD (   /sbin/rmmod -as)
May 24 16:20:01 sirius kernel: Device not ready.  Make sure there is a disc
in the drive.
May 24 16:20:23 sirius last message repeated 11 times
May 24 16:20:34 sirius kernel: scsi : aborting command due to timeout : pid
82939, scsi0, channel 0, id 1, lun 0 Test Unit Ready 00 00 00 00 00
May 24 16:20:44 sirius kernel: scsi : aborting command due to timeout : pid
82939, scsi0, channel 0, id 1, lun 0 Test Unit Ready 00 00 00 00 00
May 24 16:20:44 sirius kernel: SCSI host 0 abort (pid 82939) timed out -
resetting
May 24 16:20:44 sirius kernel: SCSI bus is being reset for host 0 channel
0.
May 24 16:20:46 sirius kernel: scsi : aborting command due to timeout : pid
82939, scsi0, channel 0, id 1, lun 0 Test Unit Ready 00 00 00 00 00
May 24 16:20:46 sirius kernel: SCSI host 0 abort (pid 82939) timed out -
resetting
May 24 16:20:46 sirius kernel: SCSI bus is being reset for host 0 channel
0.
May 24 16:20:46 sirius kernel: scsi : aborting command due to timeout : pid
82939, scsi0, channel 0, id 1, lun 0 Test Unit Ready 00 00 00 00 00
May 24 16:20:46 sirius kernel: SCSI host 0 abort (pid 82939) timed out -
resetting
.
.May 24 16:21:06 sirius kernel: SCSI bus is being reset for host 0 channel
0.
May 24 16:21:06 sirius kernel: scsi : aborting command due to timeout : pid
82939, scsi0, channel 0, id 1, lun 0 Test Unit Ready 00 00 00 00 00
May 24 16:21:06 sirius kernel: SCSI host 0 abort (pid 82939) timed out -
resetting
May 24 16:21:06 sirius kernel: SCSI bus is being reset for host 0 channel
0.
May 24 16:21:06 sirius kernel: hdc: ATAPI reset complete
May 24 16:21:12 sirius kernel: cdrom: This disc doesn't have any tracks I
recognize!
May 24 16:21:44 sirius last message repeated 17 times
May 24 16:22:46 sirius last message repeated 31 times
May 24 16:23:47 sirius last message repeated 30 times
May 24 16:24:41 sirius last message repeated 27 times

Finally, the burning process is interrupted
.


Expected Results:  All kernel messages in /var/log/messages file must not
be
gerated and the burning process must finish. 

Additional info:

uname -a
Linux sirius 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000 i686 unknown

I'm using ide-scsi module (in /var/log/dmesg)
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
scsi : 1 host.
  Vendor: LG        Model: CD-ROM CRD-8480M  Rev: 1.01
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
  Vendor: HP        Model: CD-Writer+ 7200   Rev: 3.01
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
sr0: scsi3-mmc drive: 48x/48x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.10
sr1: scsi3-mmc drive: 2x/6x writer cd/rw xa/form2 cdda tray
Comment 1 Arjan van de Ven 2001-05-25 04:04:13 EDT
Are you by chance running magicdev (gnome) or autorun (kde) ?
Those programs poll the CD at intervals to see if there is a CD,
they might get confused by a blank one..
Comment 2 Luis Gerardo de la Fraga 2001-05-28 11:56:18 EDT
Ok! I was running magicdev (gnome). The workaround was disable any control of
gnome over the CD, save the session, and reboot the machine (reboot was
necessary). Clearly the bug is on gnome's magicdev or on cdrecord program.

Note You need to log in before you can comment on or make changes to this bug.