Bug 422251 - Change in ldif format accepted by ldapmodify in openldap-2.4
Summary: Change in ldif format accepted by ldapmodify in openldap-2.4
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-12 18:35 UTC by Mark McLoughlin
Modified: 2008-01-14 12:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 12:24:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2007-12-12 18:35:10 UTC
I haven't looked into this in enough detail to know whether this was intended,
but here's what I'm seeing.

Given an existing entry:

  dn: dc=markmc,dc=org
  objectClass: top
  objectClass: domain
  dc: markmc

and wanting to change it to:

  dn: dc=markmc,dc=org
  objectClass: top
  objectClass: domain
  objectClass: pilotObject
  dc: markmc
  info: foo

This worked with openldap-clients-2.3.38-3.fc8 as input to ldapmodify:

  dn: dc=markmc,dc=org
  changetype: modify
  add: objectClass
  objectClass: pilotObject
  info: foo

With openldap-clients-2.4.6-1.fc9, I get this:

  ldapmodify: wrong attributeType at line 5, entry "dc=markmc,dc=org"

Changing to the following works:

  dn: dc=markmc,dc=org
  changetype: modify
  add: objectClass
  objectClass: pilotObject
  -
  add: info
  info: foo

Comment 1 Jan Safranek 2008-01-14 12:24:54 UTC
ldapmodify in OpenLDAP-2.4 has new parser of ldif input, which is fast, but more
strict. It you announce that you want to add an attribute, you must add only
attribute of the announced type.

E.g. using this snippet:
    changetype: modify
    add: objectClass
you can add only objectClass attributes; info attribute results in the error you
see.





Note You need to log in before you can comment on or make changes to this bug.