Bug 422411 - Perl 5.5.8 cannot find its modules
Perl 5.5.8 cannot find its modules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 15:50 EST by David K. Means
Modified: 2008-03-07 10:30 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-5.8.8-36.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 10:30:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David K. Means 2007-12-12 15:50:59 EST
Description of problem:
  On installation (via pup) perl cannot find its modules, even though they were
moved to /usr/lib/perl5/site_perl/5.8.8, presumably by the rpm package.  Attempt
to re-install them via CPAN breaks with "uninitialized value in concatenation
(.) or string at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/Scalar/Util.pm
line 30."  This line is a call to Carp::croak("$1 is only avaliable with the XS
server").  [PS: available is mis-spelled in this error message, but we'll let
that pass]

Version-Release number of selected component (if applicable): 5.8.8


How reproducible:
I only tried it once.  The system is now broken badly enough that nearly no perl
scripts work.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marcela Mašláňová 2008-02-18 08:38:42 EST
For Scalar::Util I found this:
http://www.nntp.perl.org/group/perl.cpan.testers/2007/07/msg538118.html
It looks like Scalar::Util bug, which should be fixed in upstream first.

The problem with broken packages could be caused by mixed rpm modules and cpan
modules. I done it once and had to reinstall all perl packages manually.
Comment 2 David K. Means 2008-02-22 12:59:50 EST
I should have written all this down when I remembered the details.  I eventually
got past this problem when I found that a generated script file (I've forgotten
which one) contained a NULL (^@) character at a point where some splice had
occurred during the Make operation.  I removed this character, and everything
worked fine thereafter.  Sorry for the lack of detail; maybe it will be a clue
anyway.
Comment 3 Marcela Mašláňová 2008-03-07 10:30:47 EST
The package perl-5.8.8-36 upgrade the Scalar::Util on the latest version. The
problem with XS support, weaken and other functions provided by Scalar::Util
should be fixed by this update.
If you problem persist, please feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.