Bug 422451 - need to use ata_piix in place of piix for our IDE devices
Summary: need to use ata_piix in place of piix for our IDE devices
Status: CLOSED DUPLICATE of bug 230541
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: All Linux
high
high
Target Milestone: ---
: ---
Assignee: Kimball Murray
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks: 217119
TreeView+ depends on / blocked
 
Reported: 2007-12-12 21:11 UTC by Charlotte Richardson
Modified: 2009-06-20 01:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 21:22:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch file for drivers/ide/pci/piix.c (339 bytes, patch)
2007-12-12 21:11 UTC, Charlotte Richardson
no flags Details | Diff
Same patch as before (513 bytes, patch)
2007-12-13 16:39 UTC, Kimball Murray
no flags Details | Diff
updated patch for piix.c to not claim Stratus ESB2 IDE device (462 bytes, patch)
2007-12-14 18:39 UTC, Charlotte Richardson
no flags Details | Diff
patch file for drivers/ide/pci/piix.c (468 bytes, patch)
2007-12-17 19:18 UTC, Charlotte Richardson
no flags Details | Diff

Description Charlotte Richardson 2007-12-12 21:11:59 UTC
Description of problem:
For our hardware here at Stratus Technologies, we need to be able to use
ata_piix.ko in place of the linked-in piix.c driver for our ESB2-based IDE
devices (DVDROMs) because of our hot-plug requirements. The attached patch to
piix.c causes it to not claim this particular device so that ata_piix can claim
it instead, as we require.

Comment 1 Charlotte Richardson 2007-12-12 21:11:59 UTC
Created attachment 286161 [details]
patch file for drivers/ide/pci/piix.c

Comment 2 Prarit Bhargava 2007-12-13 16:02:30 UTC
Assigning to Kimball Murray, RH's onsite Stratus engineer.

P.

Comment 3 Kimball Murray 2007-12-13 16:39:11 UTC
Created attachment 287571 [details]
Same patch as before

This patch generated against 2.6.18-59, and from above the base of the linux
tree.

Comment 4 Prarit Bhargava 2007-12-13 18:51:31 UTC
Kimball, are the Stratus boxes in RHTS?

If not, could you rig them up so I could use one of them?

(I think I may have a better solution to this problem)

P.

Comment 5 Prarit Bhargava 2007-12-14 14:03:57 UTC
Are Stratus' PCI IDs in the upstream kernel?

P.

Comment 6 Charlotte Richardson 2007-12-14 18:39:02 UTC
Created attachment 289331 [details]
updated patch for piix.c to not claim Stratus ESB2 IDE device

Updated to include Alan Cox's suggestions.

Comment 7 Aristeu Rozanski 2007-12-17 15:56:54 UTC
Did you tried to use ideX=noprobe as kernel parameter?


Comment 8 Charlotte Richardson 2007-12-17 18:05:45 UTC
ideX=noprobe does not help, since we need the devices to be probed (and to be
hotplugged). But we need to be able to replace piix.c with ata_piix.c in order
to use libata.

Comment 9 Aristeu Rozanski 2007-12-17 18:19:22 UTC
ideX=noprobe will avoid the built-in drivers/ide driver to probe a given address
for a ide controller. pata_piix then will have the chance to control it, as it'll
be built in as a module.
If it works (I never tried) it'd avoid breaking existing setups
(think hda -> sda) while allowing users to use the libata version.


Comment 10 Charlotte Richardson 2007-12-17 19:18:49 UTC
Created attachment 289797 [details]
patch file for drivers/ide/pci/piix.c

Modified the whitespace in the same patch as before, at the suggestion of
Prarit Bhargava.

Comment 13 Kimball Murray 2008-01-02 21:43:34 UTC
Hi Prarit,  any updates on this?  Are you waiting for me to re-POST with with
the whitespace changes?


Comment 14 Prarit Bhargava 2008-01-02 22:52:15 UTC
:)  Repost with whitespace change please :)

Thanks,

P.

Comment 15 Andrius Benokraitis 2008-01-15 18:16:47 UTC
Kimball/Prarit, did this get re-posted with the whitespace changes?

Comment 16 Prarit Bhargava 2008-01-16 15:34:48 UTC
Was reposted to RHKL a week or two ago.

P.

Comment 17 Andrius Benokraitis 2008-01-16 16:07:52 UTC
Prarit, unfortunately, it looks like there were pre-existing concerns from Alan
and Aris that still need clearing up as requested from Don Zickus.

Comment 21 Prarit Bhargava 2008-01-17 21:22:01 UTC
It looks like Alan's patch in 230541 resolves this issue.  His patch has been
posted to RHKL.

P.

*** This bug has been marked as a duplicate of 230541 ***


Note You need to log in before you can comment on or make changes to this bug.