Bug 42252 - rhn_register crash again
rhn_register crash again
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
6.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 05:47 EDT by inver
Modified: 2015-01-07 18:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 17:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description inver 2001-05-25 05:47:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
While runs rhn_register it crash

How reproducible:
Always

Steps to Reproduce:
1.run rhn_register
2.Do the steps you see at monitor
3.Wait for the crash
	

Actual Results:  None

Additional info:

Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 590, in __init__
    self.versionLabel2 = snack.Label(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 121, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range
Comment 1 Need Real Name 2001-05-31 06:02:13 EDT
Same thing happens to me on Redhat 7.1 on a P166. Bug happens right after
clicking "next"
In the "send profile information"-window. rhn_register also crashes when using
rhn_register --nox
Comment 2 Steve 2001-06-18 10:43:33 EDT
I too have this problem, with a configuration similar to the original reporter. 
Dell Server i586 running linux 6.2. fresh install of all files listed for "non 
X" configuration at https://www.redhat.com/network/service/rhl_62.html.

I get as far as clicking next after entering user/password and email address. 
Due to this error am unable to use this feature. I would be interested in 
knowing the full dependency listing for up2date-2.5.4-0.6.x.i386.rpm

The error I receive is listed as follows:

Traceback (innermost last):

File "/usr/sbin/rhn_register", line 119, in ?
main()
File "/usr/sbin/rhn_register", line 100, in main
tui.main()
File "/usr/share/rhn_register/tui.py", line 1033, in main
tui.run()
File "/usr/share/rhn_register/tui.py", line 982, in run
win= self.windows[index](self.screen,self)
File "/usr/share/rhn_register/tui.py", line 422 in __init__
self.emailContactButton.setValue("*")

AttributeError: setValue
Comment 3 Richard Hansen 2001-06-21 16:09:33 EDT
I am having the same issue as the original poster.  I have tried it on 3 
different RedHat 6.2 machines with different versions of rhn_register and 
up2date.

Always reproducable.
Steps to reproduce:
Start rhn_register (either X or nox mode)
Continue until it dies

Errors received:
In X mode, some strange things happen before getting the error.  The very first 
page of the wizard is completely blank except for a couple of RedHat graphics.  
After hitting next, it presents the privacy statement and the display seems to 
be normal.  At the page asking for a profile name, service ID number, and 
whether or not to "include information about hardware and network", the IP 
address reported is 127.0.0.1 (the eth0 IP is set to a private IP address via 
DHCP and I can connect to the Internet just fine through a NAT gateway, so my 
network connection is not a problem) and the Red Hat Linux version 
says "ERROR".   As soon as this page is displayed, the following error is 
printed to the terminal:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/register/gui.py", line 446, in onProfilePagePrepare
    label.set_text(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 122, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range

If I continue through the wizard, it builds a list of packages installed and 
starts to upload to RedHat, but almost immediately after starting to upload, an 
error dialog comes up saying "Problem registering system."

In nox mode, after entering a username, password, and e-mail address and 
hitting next, the following error is outputted:

Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1044, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 993, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 601, in __init__
    self.versionLabel2 = snack.Label(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 122, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range

Here are the versions I'm currently using (although I've tried earlier versions 
and am getting the same thing):

[rhansen@test ~]$ rpm -qa|grep rhn

rhn_register-1.3.6-1
rhn_register-gnome-1.3.6-1

[rhansen@test ~]$ rpm -qa|grep up2date

up2date-2.5.4-0.6.x
up2date-gnome-2.5.4-0.6.x

Comment 4 Richard Hansen 2001-06-27 15:14:42 EDT
PROBLEM SOLVED!

Doing an rpm --rebuilddb makes "db.findbyprovides("redhat-release")[0]" very 
happy.  I should have figured that one out a while ago...  :)

rpm --rebuilddb  should *definitely* be included in the documentation on how to 
get RedHat 6.2 to be happy with rhn_register.

The weird X display issues I was having were caused by having no KDE packages 
installed on the machine (the machine was running fvwm2).

I think that the comment from stevea@thenews-messenger.com is unrelated to this 
bug, so I'm not sure if rebuilding the RPM database will help him out.

Have fun everyone.
Comment 5 Adrian Likins 2001-07-06 00:21:37 EDT
Yes, rebuilding the rpmdb is a proper fix for this problem.
Comment 6 Steve 2001-07-06 10:22:12 EDT
No, rebuilddb has not resolved the problem for me. I've performed the rpm --
rebuilddb and still have the problem. The following is received the moment I 
select next after entering the user/password/e-mail information:

Traceback (innermost last):

File "/usr/sbin/rhn_register", line 119, in ?
main()
File "/usr/sbin/rhn_register", line 100, in main
tui.main()
File "/usr/share/rhn_register/tui.py", line 1033, in main
tui.run()
File "/usr/share/rhn_register/tui.py", line 982, in run
win= self.windows[index](self.screen,self)
File "/usr/share/rhn_register/tui.py", line 422 in __init__
self.emailContactButton.setValue("*")

AttributeError: setValue
__________________

I have rpm -q'd all files (which redhat has listed) as required for rhn, and 
have confirmed that the packages are of the latest versions. My server is nox. 
Please advise.
Comment 7 Adrian Likins 2001-07-06 14:40:25 EDT
There are two problems in this bug report.

The problem with finding the "redhat-release" package is solved by
rebuilding the rpmdb.

The problem with the tui client will be fixed by an update of the
registration client.

Note You need to log in before you can comment on or make changes to this bug.