Bug 42253 - anaconda crash because of too small partition size for /
anaconda crash because of too small partition size for /
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 06:21 EDT by Niels Kristian Jensen
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-04 13:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Kristian Jensen 2001-05-25 06:21:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
Standard crash, the the user is prompted to send in a bugzilla report using
a floppy disk to hold the description

How reproducible:
Always

Steps to Reproduce:
1. Select partitions too small
2. Select packages
3. After the error message saying that the / partition is too small, a
crash follows
	

Actual Results:  Nothing - a reboot is needed

Expected Results:  As is - but without a crash following the error message

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1925, in
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File
"/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py",
line 134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage/drive_d
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>
Comment 1 Brent Fox 2001-05-25 16:21:49 EDT
Weird.  I can't reproduce this.  I made a / partition that was 50MB in size.  In
disk druid, but after formatting the partition, I got a message saying that I
don't have enough disk space to install.  Clicking ok then allows me to go back
to the package selection screen.  

What were the sizes of the partitions that you made?
Comment 2 Niels Kristian Jensen 2001-05-27 03:42:06 EDT
I've got a 8 gig disk with 4 partions:

circa 1000 megs fat16 for DOS
circa 1000 megs linux native for /
circa 70 megs for swap
circa 4996 megs for fat32 (windows'98)
circa 1 gig unallocated

These numbers are from memory. I got around the problem by deleting the linux native and the linux swap partions, re-creating the swap (100 megs) and 
allowing the linux native partion to use remaining space.
Comment 3 Brent Fox 2001-05-31 14:19:25 EDT
Did you happen to set mount points for the DOS partitions on the times when it
failed?
Comment 4 Niels Kristian Jensen 2001-05-31 16:59:26 EDT
I set mountpoints as follows:

/c_drive
/
(swap)
/d_drive

or - I don't recall - it was this setup:

/drive_c
/
(swap)
/drive_d
Comment 5 Brent Fox 2001-05-31 17:55:32 EDT
I think that might be the source of the problems.  There seem to be some
problems with setting mount points for DOS partitions during the install.  Does
the installer work correctly if you don't set mount points fos DOS partitions?
Comment 6 Niels Kristian Jensen 2001-06-01 00:39:44 EDT
There was no problem with the installer and DOS partitions, if all partitions were big enough (See my 2001-05-27 03:42:06 comment)

I haven't tried with a too small partition for the "/" mountpoint and no DOS partition, since I got it to work as described.
Comment 7 Brent Fox 2001-06-04 13:30:52 EDT
I can't explain why deleting the partitions and then recreating them would make
a difference, but it seems like you've found a workaround.

Note You need to log in before you can comment on or make changes to this bug.