Bug 422621 - seahorse preferences doesn't show option to change gnome-keyring password
seahorse preferences doesn't show option to change gnome-keyring password
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 17:54 EST by Jens Lautenbacher
Modified: 2015-03-03 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-15 17:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Lautenbacher 2007-12-12 17:54:14 EST
Contrary to the documentation (website, also the documentation that can be
browsed in yelp), there is no tab "gnome keyring" that allows to change the
passphrase of the gnome-keyring.

This is for versions up to at least seahorse-2.21.3-1.fc8
Comment 1 Jens Lautenbacher 2008-06-15 17:42:21 EDT
this is fixed with the version as it is supplied in fedora 9
(seahorse-2.22.2-1.fc9.i386)

Comment 2 Renato Ramonda 2009-07-27 05:19:59 EDT
It used to work (I used it in Fedora 10), it looks like it doesn't anymore.

I'm using:

seahorse-2.26.2-1.fc11.i586
seahorse-plugins-2.26.2-2.fc11.i586

The tab is not there.
Comment 3 Kevin R. Page 2009-09-08 09:56:50 EDT
Also no "Gnome Keyring" tab in seahorse-2.26.2-1.fc11

Given the starting point of Evolution telling me my default login password didn't match [1] it's not really intuitive where I should fine this (or how to change it).

[1] I'd imagine it's not meant to get out of sync, but /home was restored from backup
Comment 4 Renato Ramonda 2009-09-08 10:09:16 EDT
Today I found myself how to do this in the current version:

1 - Open Passwords and Encription Keys

2 - Click on the last tab: Passwords

3 - Here there should be a folder named "Passwords: login" that can be expanded to see the keyring.

4 - Right-Click on that folder and click on Change Password.

You are presented with the classic "old password, new password, confirm password" dialog.

I just want to point out that this is NOT DISCOVERABLE AT ALL.

The easiest way would probably to put a button on the unlock dialog you get at login when there is a password mismatch (that is, any time your login password is different from the keyring one for any reason) offering you to trigger the change password dialog.

This way people that face this problem for the first time (when they change their password because of personal or company policy) they receive the "unlock keyring" dialog with the clear option to make it go away again.
Comment 5 Kevin R. Page 2009-09-08 12:17:16 EDT
(Could owner or reporter re-open, please?)

(In reply to comment #4)
> I just want to point out that this is NOT DISCOVERABLE AT ALL.

Indeed, I found my way there by a process of elimination earlier today, but then I kind of know what I'm doing. It was certainly less obvious than gnome-keyring-manager, which I used last time.

If I remember correctly, the Evolution dialog mentioned the "default(?) keyring". Some consistent terminology might help here... I suspect that the "key" in "keyring" subconsciously had me looking in the keys tabs (until I thought about it!).

I note that when creating a new instance, seahorse calls it a "Password Keyring", so perhaps this would be a more consistent title for the tab (rather than just "Passwords").

Similarly "login" isn't an immediately obvious name for the keyring if you arrive from e.g. Evolution. Is it possible to have a description field?


> The easiest way would probably to put a button on the unlock dialog you get at
> login when there is a password mismatch (that is, any time your login password
> is different from the keyring one for any reason) offering you to trigger the
> change password dialog.

Yes, some kind of warning that the login doesn't match the keyring with a shortcut to the change password dialog would help.

Note You need to log in before you can comment on or make changes to this bug.