Bug 42272 - gpg is unable to allocate secure memory
Summary: gpg is unable to allocate secure memory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-25 14:06 UTC by Vidar Langseid
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version: 8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 11:19:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vidar Langseid 2001-05-25 14:06:33 UTC
Description of Problem:

I have a encrypted text file. Often when I try to decrypt it I get a
errormessaes like this:


You need a passphrase to unlock the secret key for
user: "admin (keys for admin) <drift@lists.ez.no>"
2048-bit ELG-E key, ID D9AF6691, created 2000-08-28 (main key ID 42102D4C)
 
gpg: Invalid passphrase; please try again ...
 
You need a passphrase to unlock the secret key for
user: "admin (keys for admin) <drift@lists.ez.no>"
2048-bit ELG-E key, ID D9AF6691, created 2000-08-28 (main key ID 42102D4C)
 
gpg: fatal: out of secure memory while allocating 4316 bytes
secmem usage: 1472/11392 bytes in 3/9 blocks of pool 12160/16384



How Reproducible: Not allways, Often after I have written the passphrase
wrong the first time


Steps to Reproduce:
1. Write wrong passphrase the first time
2. I then often have to retry miltiple times before I will be able to
decrypt the file
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Vidar Langseid 2003-04-16 11:19:52 UTC
Haven't experienced this in a long time.
Unable to reproduce in rh9, and I don't think it ever happend with rh8

Changed status to resolved


Note You need to log in before you can comment on or make changes to this bug.