Bug 42283 - I am getting "free list corrupt" message when using rpm
I am getting "free list corrupt" message when using rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 11:05 EDT by Jeba Bhaskaran
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 10:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file of rpm db (deleted)
2001-05-25 11:08 EDT, Jeba Bhaskaran
no flags Details
rpm db tar file (deleted)
2001-05-25 11:14 EDT, Jeba Bhaskaran
no flags Details
rpm db tar file (deleted)
2001-05-25 11:17 EDT, Jeba Bhaskaran
no flags Details
My rpm db for which I get a "corrupt free list" on RH 6.2 (deleted)
2001-05-25 12:57 EDT, Marco Antoniotti
no flags Details
RPM db for which I get a free list corrupt error on RH 6.2. (deleted)
2001-05-25 13:18 EDT, Marco Antoniotti
no flags Details

  None (edit)
Description Jeba Bhaskaran 2001-05-25 11:05:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:


How reproducible:
Always

Steps to Reproduce:
1. run rpm
2.
3.
	

Additional info:
Comment 1 Jeba Bhaskaran 2001-05-25 14:30:43 EDT
any idea when a fix might be available?
Comment 2 Jeff Johnson 2001-05-25 14:41:40 EDT
There are 3-6 recent rpm bugs with db1 databases damaged by Ximian, the "fix"
is approx. the same. Meanwhile, I'm gonna try to add a better fix to rpm-4.0.3
to address
db1 damage, that's gonna take a few days ...
Comment 3 Jeba Bhaskaran 2001-05-30 11:58:44 EDT
sorry to keep bugging you. do you think the fix would be available by the end of
week? I need to upgrade some installed packages
Comment 4 Jeff Johnson 2001-05-30 15:23:30 EDT
Dunno when yet, soon. I've got a fix for about half the problems (sorry
not yours yet), looking at your class of  "free-list corrupt" damage
next ...
Comment 5 Jeff Johnson 2001-05-30 15:42:02 EDT
Your free-list is corrupt after offset 17543768 in packages.rpm.
Since the file size is

-rw-r--r--    1 root     root     17552072 May  3 12:54 packages.rpm

a simple rebuild using rpm-3.0.x will probably fix most everything.
	

See directions at #41864, reopen this bug if you need more.

*** This bug has been marked as a duplicate of 41864 ***
Comment 6 Jeba Bhaskaran 2001-05-30 16:16:27 EDT
when I run 'rpm2cpio rpm-3.0.4-0.48.rpm | cpio -dim' I am getting the following
error:
cannot open package: No such file or directory
cpio: premature end of archive
Comment 7 Jeff Johnson 2001-05-30 16:19:52 EDT
The argument to rpm2cpio is a path to package file ...
Comment 8 Jeff Johnson 2001-05-31 10:11:32 EDT
BTW, you may need to move the rebuilt indices from
/var/lib/rpmrebuild* to /var/lib/rpm. after rebuildding.
Make sure you get the latest rebuilddb directory, as
every free list corrupt exit leaves a directory behind.
All the /var/lib/rpmrebuild* directories can/should be
removed.
Comment 9 Jeba Bhaskaran 2001-05-31 14:24:24 EDT
working now. Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.