Bug 423151 - bodhi -M gives me 'NoneType' object is unsubscriptable
bodhi -M gives me 'NoneType' object is unsubscriptable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-fedora (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 05:54 EST by Lubomir Kundrak
Modified: 2016-09-19 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.2.90.22-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 15:21:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-12-13 05:54:34 EST
Description of problem:

$ bodhi -M
Password for lkundrak: 
Traceback (most recent call last):
  File "/usr/bin/bodhi", line 320, in <module>
    bodhi.masher()
  File "/usr/bin/bodhi", line 147, in masher
    data = self.send_request('admin/masher', auth=True)
  File "/usr/lib/python2.5/site-packages/fedora/tg/client.py", line 168, in
send_request
    data = self.send_request(method, auth, input)
  File "/usr/lib/python2.5/site-packages/fedora/tg/client.py", line 174, in
send_request
    data['message'],)
TypeError: 'NoneType' object is unsubscriptable
$

-v gave me no more information.

Version-Release number of selected component (if applicable):

bodhi-client-0.4.6-1.fc8
Comment 1 Luke Macken 2007-12-14 10:56:39 EST
The `bodhi -M` command is restricted to Release Engineering only, but the
traceback is caused by a bug in python-fedora which I just fixed[0].  Once this
change goes out, `bodhi -M` probably just re-prompt you for your credentials.


[0]:
http://bzr.fedorahosted.org/bzr/python-fedora-python-fedora-devel?cmd=revision;revid=lmacken%40redhat.com-20071214153916-5qnlm2m4mx4lxwlo
Comment 2 Fedora Update System 2007-12-20 15:13:39 EST
python-fedora-0.2.90.22-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-fedora'
Comment 3 Fedora Update System 2007-12-20 15:13:45 EST
python-fedora-0.2.90.22-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-fedora'
Comment 4 Fedora Update System 2007-12-28 12:15:22 EST
python-fedora-0.2.90.22-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-12-28 12:16:33 EST
python-fedora-0.2.90.22-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.