Bug 423311 - KVM: Exception 6 before being able to enter Ubuntu CD boot selector
KVM: Exception 6 before being able to enter Ubuntu CD boot selector
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 427858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 07:45 EST by Lubomir Kundrak
Modified: 2008-01-31 00:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 22:35:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-12-13 07:45:51 EST
Description of problem:

When I try to boot ubuntu-7.10-desktop-i386.iso with KVM, I get an exception 6
before I am able to enter boot loader's menu. I suspect its graphics mode change
might be to blame.

Version-Release number of selected component (if applicable):

kvm-53-1.fc9

Additional info:

$ qemu-kvm -boot d -cdrom ~/ubuntu/ubuntu-7.10-desktop-i386.iso 
Warning: No DNS servers found
exception 6 (0)
rax 0000000000000469 rbx 0000000000800001 rcx 0000000000004300 rdx 0000000000000000
rsi 000000000005961d rdi 000000000005961c rsp 00000000fffaa9cc rbp 000000000000200c
r8  0000000000000000 r9  0000000000000000 r10 0000000000000000 r11 0000000000000000
r12 0000000000000000 r13 0000000000000000 r14 0000000000000000 r15 0000000000000000
rip 000000000000b04b rflags 00033006
cs 4143 (00041430/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ds 4004 (00040040/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
es 4004 (00040040/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ss 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
fs 3002 (00030020/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
gs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
tr 0000 (08c00000/00002088 p 1 dpl 0 db 0 s 0 type b l 0 g 0 avl 0)
ldt 0000 (00000000/0000ffff p 1 dpl 0 db 0 s 0 type 2 l 0 g 0 avl 0)
gdt 40920/47
idt 0/ffff
cr0 60000010 cr2 0 cr3 0 cr4 0 cr8 0 efer 0
code: 0f 17 3e 28 08 02 28 3e 01 17 0f 17 46 28 08 02 28 0e 01 17 --> 0f 17 3e
28 08 02 28 5d 01 17 0f 28 08 02 28 5e 01 17 0f 17 3b 28 08 02 28 5f 01 17 0f 28
Aborted (core dumped)
$

I am putting Daniel into CC, as I first treid that with virt-manager, and was
unable to find out why wasn't I able to start the VM. virt-manager should report
such failure and possibly the kvm output in some way to the user and suggest
opening a bugzilla ticket.
Comment 1 Josh Cogliati 2008-01-16 18:33:18 EST
This may be the same as bug 427858
Comment 2 petrosyan 2008-01-16 18:59:30 EST
*** Bug 427858 has been marked as a duplicate of this bug. ***
Comment 3 Josh Cogliati 2008-01-23 10:03:49 EST
As noted in bug 427858 this also occurs with openSUSE-10.3 LiveCD.
Comment 4 Lubomir Kundrak 2008-01-23 12:13:26 EST
As well as with alpha of openSUSE 11 after being installed.
Jeremy: Would it make sense if we reported it upstream?
Comment 5 Jeremy Katz 2008-01-28 22:35:48 EST
Already known upstream, but it's actually a bug in gfxboot, not kvm.  It's
trying to use code which cannot work under VT -- see
https://sourceforge.net/tracker/?func=detail&atid=893831&aid=1798813&group_id=180599
Comment 6 Josh Cogliati 2008-01-31 00:45:51 EST
I check and there are bugs filed in both Ubuntu and OpenSUSE.
Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/gfxboot/+bug/140713
OpenSUSE:
https://bugzilla.novell.com/show_bug.cgi?id=307194

Note You need to log in before you can comment on or make changes to this bug.