Bug 423411 - Make bodhi-client pass --verbose to python-fedora
Summary: Make bodhi-client pass --verbose to python-fedora
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-13 14:04 UTC by Lubomir Kundrak
Modified: 2016-09-20 02:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 18:19:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lubomir Kundrak 2007-12-13 14:04:52 UTC
Description of problem:

This causes the --verbose parameter passwd bodhi work for the underlying
python-fedora interface.

--- /usr/bin/bodhi.orig 2007-12-13 14:58:33.000000000 +0100
+++ /usr/bin/bodhi      2007-12-13 14:58:21.000000000 +0100
@@ -286,7 +286,7 @@
     (opts, args) = parser.parse_args()
     setup_logger()
 
-    bodhi = BodhiClient(BODHI_URL, opts.username, None)
+    bodhi = BodhiClient(BODHI_URL, opts.username, None, opts.verbose)
 
     def verify_args(args):
         if not args and len(args) != 1:

Comment 1 Lubomir Kundrak 2007-12-13 14:16:42 UTC
passwd should have been 'passed to', and the sentence should have made sense. I
was just temporarily dyslectic due to excitement for first python patch of mine :)

Comment 2 Luke Macken 2007-12-14 16:39:39 UTC
I applied the patch in my development branch.  This will go out with the next
bodhi update.

Comment 3 Fedora Update System 2007-12-20 19:50:25 UTC
bodhi-0.4.8-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bodhi'

Comment 4 Fedora Update System 2007-12-20 20:15:07 UTC
bodhi-0.4.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bodhi'

Comment 5 Fedora Update System 2007-12-28 17:14:52 UTC
bodhi-0.4.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-12-28 17:15:58 UTC
bodhi-0.4.8-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.