Bug 4235 - RH6.0 & glib-1.2.3-2.i368.rpm
RH6.0 & glib-1.2.3-2.i368.rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gimp-data-extras (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-28 01:25 EDT by banasw01
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-02 12:30:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description banasw01 1999-07-28 01:25:49 EDT
This is a bug with glib-1.2.3-2.i386.rpm from www.gtk.org. I
wanted to upgrade glib because I wanted to use newer X11amp
and once I upgrade glib and exit my desktop/window manager
to the login menu, I can not log in anymore and it is hard
to shut down. When I try to log in, the screen flashes like
I would be changing resolution or restatring X, and it
brings me back to login. I can shut down by tapping Ctrl+Alt
Delete and Ctrl+Alt Backspace. I have reinstalled my system
about 5-6 times now to make sure this IS the problem. I
upgrade glib righ after I install RH and I get this problem.
I use Window Maker, I haven't tested this problem on GNOME
or KDE, because I don't want to reinstall for the Nth time.
Am I doing something wrong? Am I asking a stupid question?
Did I provide enough info?
Thanks
Comment 1 Jeff Johnson 1999-09-02 12:30:59 EDT
The dependency chains in GNOME are pretty deep. You might try
upgrading to the packages in Raw Hide paying careful attention
to the dependency failures from rpm. That means that you will
have to download each Raw Hide package, install manually as
	rpm -Uvh <package1> ...
and add packages to satisfy dependency failures until success is
achieved.

Alternatively, download the x11amp src.rpm and build as
	rpm --rebuild x11amp*.src.rpm
and install with
	rpm -Uvh /usr/src/redhat/RPMS/i386/x11amp*rpm

If the build fails, you probably should try the upgrade path from
Raw Hide.

In any case, you shouldn't have to reinstall the entire system to
fix a broken dependency. Just do
	rpm -Uvh --force <old_glib_package>
to reinstall the previous glib package.
(Note: --force is not a panacea for packages that won't install, so
don;'t use it when trying to sort out the Raw Hide dependencies.)

Note You need to log in before you can comment on or make changes to this bug.