Bug 42357 - make modules_install removes files in /lib/modules/2.4.2-2/kernel/drivers/net
make modules_install removes files in /lib/modules/2.4.2-2/kernel/drivers/net
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 19:16 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:59:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of make config command (22.22 KB, text/plain)
2001-06-04 16:28 EDT, Need Real Name
no flags Details
Output of make dep command (103.44 KB, text/plain)
2001-06-04 16:32 EDT, Need Real Name
no flags Details
Output of make clean command (2.36 KB, text/plain)
2001-06-04 16:33 EDT, Need Real Name
no flags Details
Output of make bzlilo command (Notice the errors at the end of file) (18.14 KB, text/plain)
2001-06-04 16:37 EDT, Need Real Name
no flags Details
Output of make modules command (more errors at end of file) (6.56 KB, text/plain)
2001-06-04 16:39 EDT, Need Real Name
no flags Details
Output of make modules_install command (errors at end of file output) (2.74 KB, text/plain)
2001-06-04 16:45 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-05-25 19:16:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
I had a bare bones installation of a redhat 7.1 box to be used as a 
firewall.  I have two intel ethernet pro 100 network cards.  All 
connections to the cards work after installation...I can ping outside the 
machine and so on.  I then try to recompile the kernel with a make config 
and change three things...

IP:  multicasting -> from Y to N
IP:  advanced route -> from N to Y
IP:  TCP syncookie support -> from N to Y

I leave all the other settings the same.  I then finish and do a 
make dep
make clean
make bzlilo
make modules
make modules_install
init 6

When machines comes back up eth0 and eth1 don't work any longer.  I check 
logs and find that /lib/modules/2.4.2-2/kernel/drivers/net/eepro100.o 
cannot be found.  I do a directory listing of that directory and there are 
NO files to be found.  Upon further digging and even changing the three 
settings above back I found that if I have a sample eepro100.o file in the 
above directory it will remain there until I run the make modules_install 
command upon which the directory contents are emptied.  I am planning on 
re-installing again and see if I can trace down some errors and exactly 
what is installed and what is done to the T.

How reproducible:
Always

Steps to Reproduce:
1. Install OS with bare bones installation plus a minute handful of 
applications.
2. Recompile kernel with make config...make dep;make clean;make 
bzlilo;make modules;make modules_install;init 6
3. 
	

Actual Results:  I believe after the make modules_install it wipes out 
the /lib/modules/2.4.2-2/kernel/drivers/net by deleting all files 
contained in it.  Thus insmod fails when booting up because it cannot find 
module file.

Expected Results:  Modules should have stayed put.  I did double check 
when going through compilation steps that the eepro100 was set to 
Y...Can't get network cards working without totally reinstalling.  Then, I 
can't tune the kernel without losing network cards again.  :)

Additional info:

Will try to get more information on Tuesday...
Comment 1 Arjan van de Ven 2001-05-28 05:09:53 EDT
"eepro100 was set to  Y" -> this will NOT give you a module!
It will build the driver into the kernel instead.

If you make it "M" then it will generate a module.

Also, which file out of "configs/" did you pick, or did you do the entire
configuration yourself ?
Comment 2 Need Real Name 2001-06-04 16:28:02 EDT
Created attachment 20253 [details]
Output of make config command
Comment 3 Need Real Name 2001-06-04 16:32:30 EDT
Created attachment 20254 [details]
Output of make dep command
Comment 4 Need Real Name 2001-06-04 16:33:59 EDT
Created attachment 20255 [details]
Output of make clean command
Comment 5 Need Real Name 2001-06-04 16:37:15 EDT
Created attachment 20256 [details]
Output of make bzlilo command (Notice the errors at the end of file)
Comment 6 Need Real Name 2001-06-04 16:39:18 EDT
Created attachment 20257 [details]
Output of make modules command (more errors at end of file)
Comment 7 Need Real Name 2001-06-04 16:45:12 EDT
Created attachment 20258 [details]
Output of make modules_install command (errors at end of file output)
Comment 8 Arjan van de Ven 2001-06-04 16:51:47 EDT
random.c: In function `random_read':
random.c:1500: Internal compiler error in flow_depth_first_order_compute, at
flow.c:7421
Please submit a full bug report.

is a gcc bug.

And you forgot to use "make mrproper" as your first command.

Note You need to log in before you can comment on or make changes to this bug.