Bug 423761 - Inappropriate warning about a service record
Inappropriate warning about a service record
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Radek Brich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 12:31 EST by Christopher Yeleighton
Modified: 2008-03-13 03:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0.2-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.75 KB, patch)
2008-02-18 08:10 EST, Radek Brich
no flags Details | Diff

  None (edit)
Description Christopher Yeleighton 2007-12-13 12:31:30 EST
Description of problem: 
Inappropriate warning about a leading underscore for a service entry.


Version-Release number of selected component (if applicable): 
9.5.0


How reproducible:
Add a new service entry "_ldap._tcp.YOUR-DOMAIN"

Steps to Reproduce:
1. Create a service resource record for _ldap._tcp.YOUR-DOMAIN in your domain.
2. Press OK.
  
Actual results:
Warning: domain name labels must begin with a letter or a number (RFC 1123).

Expected results:
A warning if the service name/protocol name does not begin with an underscore
(RFC 2782)

Additional info:
When I acknowledge the warning, I get a bug "Domain name must not be empty".  I
cannot enter the server name until I acknowledge all these warnings and errors.
 A workaround is to enter the server name first.
Comment 1 Radek Brich 2008-02-18 08:10:33 EST
Created attachment 295164 [details]
proposed patch

Hi,
can you please test this patch? It should fix the problem.

The patch can be applied directly on live system by
# cd /usr/share/system-config-bind && patch -b -p2 <
system-config-bind-4.0.4-srv.patch

Thank you
Comment 2 Christopher Yeleighton 2008-02-18 11:12:58 EST
Works for me.
Thanks
Comment 3 Fedora Update System 2008-02-22 09:14:27 EST
system-config-bind-4.0.2-9.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-02-25 19:22:05 EST
system-config-bind-4.0.2-9.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1920
Comment 5 Fedora Update System 2008-03-13 03:44:26 EDT
system-config-bind-4.0.2-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.