Bug 42397 - sort mis-sorts with string length mod(16)
sort mis-sorts with string length mod(16)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 42517 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-26 21:00 EDT by Robert Citek
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-26 21:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Citek 2001-05-26 21:00:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I get errors when sorting strings whose lengths are multiples of 16.

How reproducible:
Always

Steps to Reproduce:
1. in bash, run this script
2.( c="x"; list=""; length=0
  for length in $(seq 1 48); do 
    echo "length == " ${length}
    list=${list}${c} 
    echo -ne "${list}~\n${list}\n" | sort
  done )
3.
	

Actual Results:  length ==  48
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx~
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Expected Results:  length ==  48
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx~
Comment 1 Bernhard Rosenkraenzer 2001-05-27 15:47:40 EDT
This is related to the fact that recent versions of sort are locale aware. If 
you don't like it, export LC_COLLATE=C
Comment 2 Bernhard Rosenkraenzer 2001-05-28 02:44:34 EDT
*** Bug 42517 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.