Bug 424341 - Computer freezes when attacking soldiers
Computer freezes when attacking soldiers
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: 8Kingdoms (Show other bugs)
8
i386 Linux
high Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 16:36 EST by Martin Sourada
Modified: 2007-12-14 03:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 03:28:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Sourada 2007-12-13 16:36:40 EST
Description of problem:
Computer, or at least mouse and keyboard, freezes for me when trying to attack
first bunch of soldiers in the moment when first arrows hit them. I tried it in
the Introduction scenario against computer player with AI set to easy.

Version-Release number of selected component (if applicable):
8Kingdoms-1.1.0-2.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Run 8Kingdoms
2. Create a new profile if not created yet
3. Select Local Game
4. Select Introduction Scenario
5. Set game type to conquest, oponent to computer with AI easy
6. Start the game
7. Use your archers to attack one bunch of soldiers.
  
Actual results:
Computer freezes (or at least seems to).

Expected results:
The arrows hit the soldiers and their numbers are decreased.

Additional info:
Comment 1 Hans de Goede 2007-12-13 17:44:14 EST
Hmm,

Nasty I have a few questions to help diagnose this:
- What driver are you using for your graphics card? 
- Have you tried pressing CTRL+ALT+F1 all together to switch back to text mode?
- This might be a (known) kernel bug, which just causes the mouse and keyboard to
  freeze. Are you using both a ps/2 mouse and keyboard? If so can you try 
  attaching an usb mouse and / or keyboard and see if those still work?
- What does pressing numlock do
- Can you still ping / ssh to the machine from another machine on the network?
Comment 2 Martin Sourada 2007-12-13 17:59:21 EST
(In reply to comment #1)
> Hmm,
> 
> Nasty I have a few questions to help diagnose this:
> - What driver are you using for your graphics card? 
intel

> - Have you tried pressing CTRL+ALT+F1 all together to switch back to text mode?
does not work, I also tried CTRL+ALT+BACKSPACE or hitting the power button.

> - This might be a (known) kernel bug, which just causes the mouse and keyboard to
>   freeze. Are you using both a ps/2 mouse and keyboard? If so can you try 
>   attaching an usb mouse and / or keyboard and see if those still work?
I am using the keyboard on my lappy and connected usb mouse, I just remebered, I
didn't try using touchpad, but the cursor animation is frozen as well (IIRC
normally the hourglass cursor is animated)...

> - What does pressing numlock do
I tried capslock, does not do anything.

> - Can you still ping / ssh to the machine from another machine on the network?
> 
Unfortunatelly I cannot check this (don't have another computer around here) and
we are not allowed connections out of the local network. I could maybe check
that at the weekend (when I get home), but I haven't set up correct firewall
rules for home use yet (we use both wired and wireless connection and I am not
sure if I'll be let through NAT).
Comment 3 Hans de Goede 2007-12-14 03:28:42 EST
(In reply to comment #2)
> (In reply to comment #1)
> > Hmm,
> > 
> > Nasty I have a few questions to help diagnose this:
> > - What driver are you using for your graphics card? 
> intel
>

Okay, I tried reproducing this on a machine with intel graphics but it works
fine there, leaving we with little other choice as closing this as works for me. 

I guess this is a bug in mesa, please file a bug against mesa upstream:
http://bugzilla.freedesktop.org/
 
Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.