Bug 424661 - [ml_IN] Rendering problem with [Consonant] + u0d4d+0d31
[ml_IN] Rendering problem with [Consonant] + u0d4d+0d31
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 02:09 EST by A S Alam
Modified: 2013-07-02 20:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 03:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oowriter with kedit and gedit (182.63 KB, image/png)
2007-12-14 02:09 EST, A S Alam
no flags Details

  None (edit)
Description A S Alam 2007-12-14 02:09:45 EST
Description of problem:
Rendering problem with [Consonant] + u0d4d+0d31
Character should be "Un"Join

Version-Release number of selected component (if applicable):
libicu-3.8-5.fc9

How reproducible:
Everytime

Steps to Reproduce:
1. open oowriter
2. type 0d15 (any consonant except 0d31] + 0d4d+0d31
3.
  
Actual results:
it combined

Expected results:
should not combined to make a glyph (like QT or Pango)

Additional info:
1) QT/Pango working fine
2) Screenshot
Comment 1 A S Alam 2007-12-14 02:09:45 EST
Created attachment 288581 [details]
oowriter with kedit and gedit
Comment 2 Caolan McNamara 2007-12-14 03:14:24 EST
i.e. U+0D15 U+0D4D U+0D31 yes ? But that's test case 153 at

http://batman.brisbane.redhat.com/~indic/IndicTC/lang/ml_IN/font/IndicFontTestCaseGSUB-Malayalam.html

which looks just like the OOo rendering. Now I'm totally confused. How is
"working" and "not working" being determined. If there is something wrong here
can I just e.g. get the above testcase expanded for the new thing that doesn't
work, or a pointer like "test case #102 from
IndicFontTestCaseGSUB-Malayalam.html" doesn't work.
Comment 3 A S Alam 2007-12-17 02:00:34 EST
Those Test Cases Need to update (as per Confirmed with Malayalam Translator)
(which our Team will update soon).
(#153-179 Test Case need to  update)

regards
A S Alam
Comment 4 Caolan McNamara 2007-12-17 03:52:49 EST
Just let me know when we have a new testsuite I can work towards. We changed the
original behaviour which gave the results being asked for here to match those
test-cases which are now apparently not what is desired.
Comment 5 Caolan McNamara 2008-01-04 11:48:13 EST
I'll set this to NEEDINFO because I can't really work on undoing the change we
did to make the test-cases correct for this new requirement unless I can see
what the new test-cases should be to see if we need to remove the original
change totally or modify it for some sub-cases.
Comment 7 Caolan McNamara 2008-01-31 10:28:32 EST
So all the 0d31 test-cases are now the other way around. Reverted the hack that
we had in place in icu to get the original results. So should be good in
icu-3.8.1-4.fc9. The same hack for 0d30 test-cases remains.
Comment 8 Ani Peter 2008-02-04 01:10:39 EST
Hi Caolan,

Working perfect in icu-3.8.1-4.fc9. Tested and confirmed.

Thanks
Ani


Note You need to log in before you can comment on or make changes to this bug.