Bug 424721 - NetworkManager-vpnc does not retain vpn configuration
NetworkManager-vpnc does not retain vpn configuration
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-14 03:00 EST by Nik Lam
Modified: 2008-01-17 03:40 EST (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.7.0-0.6.6.svn3138.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-13 12:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nik Lam 2007-12-14 03:00:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071128 Fedora/ Firefox/

Description of problem:
I can add a new "Compatible Cisco VPN client (vpnc)" VPN configuration, populating the following fields:

Connection name
Group name
Override user name

and at the end of the process it shows me the summary screen confirming what I've entered as well as the

Cancel Back Apply

buttons. When the Apply button is pressed, it looks like the new vpn configuration has been added to the list, however, if you click on it to highlight it and then click on edit, all these fields are unpopulated and if you try to use the configuration, it just silently fails.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
see description.

Actual Results:
see description

Expected Results:
VPN configuration information should be visible and editable and it should be possible to use the vpn configuration.

Additional info:
I have an existing vpn configuration that shows up in the list which has populated configuration fields. This was created prior to the recent update to svn3109, so I wonder if there has been some kind of problem introduced with that update.

I've not tried with a fresh fedora install, but I've tried with a fresh user account and get the same result.

Using the command line version of vpnc works fine.
Comment 1 David Smith 2007-12-21 10:48:55 EST
I've seen similar problems, but my symptoms are a bit different.  After entering
 cisco vpn connection information, I can hit apply and see the new configuration
in the list.  If I try to edit the connection, nm-vpn-properties crashes.  I can
delete connections properly, just not edit them.
Comment 2 Ben Liblit 2007-12-24 08:09:41 EST
I'm also seeing the same thing in my fresh Fedora 8 installation.  This worked
fine under Fedora 7.  But under Fedora 8, editing an existing VPN connection
configuration either has all fields blank or crashes nm-vpn-properties:

* If the "VPN Connections" dialog has not been closed, then editing a
configuration you have just created brings up an connection-editing dialog with
all fields except the name blank.  This is the failure mode that Nik Lam
originally reported.

* If the "VPN Connections" dialog has been closed, then editing a configuration
you created earlier crashes nm-vpn-properties.  This is the failure mode that
David Smith described in comment #1.

In either case, new VPN connections configured under Fedora 8 are not usable. 
The critical configuration information like gateway address and group name is
missing from the stored configuration in gconf and cannot be used by
NetworkManager.  This is a clear regression from Fedora 7.

I see the following diagnostic error message, which is consistent with my
earlier claim that critical VPN properties are missing from the saved
configuration in gconf:

    ** ERROR **: file nm-vpnc.c: line 288 (impl_get_widget): \
    assertion failed: (s_vpn_props)

Here's a dump of what's actually in gconf to represent my VPN configuration:

    % gconftool-2 -R /system/networking/connections/2
      service-type = org.freedesktop.NetworkManager.vpnc
      id = WiscVPN-OffCampus
      timestamp = 0
      type = vpn
      autoconnect = false

Note the lack of a gateway IP address and group name, even though I provided
both of these when configuring the connection.
Comment 3 David Juran 2008-01-13 12:53:49 EST
Is this perchance a dup of Bug 409351? 
Anyway, this now works for me with NetworkManager-0.7.0-0.6.6.svn3138.fc8 and
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8 so I'm closing this bug.
Please re-open if the problem persists.
Comment 4 David Smith 2008-01-14 09:59:58 EST
This now works for me also.
Comment 5 Ben Liblit 2008-01-17 03:40:11 EST
Working here as well.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.