Bug 424801 - CD, USB disks are not automatically mounted
CD, USB disks are not automatically mounted
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 04:19 EST by antonio montagnani
Modified: 2013-03-05 22:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 14:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages, failing to mount a dvd (16.19 KB, text/plain)
2008-06-02 07:50 EDT, Mike Pope
no flags Details

  None (edit)
Description antonio montagnani 2007-12-14 04:19:50 EST
Description of problem:
when I attach an USB disk or I insert a CD, media are not mounted

Version-Release number of selected component (if applicable):
hal-0.5.10-3.fc9

How reproducible:
always 

Steps to Reproduce:
1.insert a CD
2.check media
3.
  
Actual results:
no automatic mount of attached/inserted device

Expected results:
they should be automaticcaly mounted

Additional info:
They were working also in rawhide but now no longer: I can't tell when it
happened, as I have not used an USB disk or CD for a long time
Comment 1 antonio montagnani 2007-12-14 04:21:29 EST
forgot to say That I can't see also shared computer on network (it was working):
my Selinus is permissive
Comment 2 shrek-m 2007-12-14 09:22:56 EST
the same here, tested with

SELINUX=disabled

and all is ok.
Comment 3 antonio montagnani 2007-12-14 09:38:22 EST
same here SELinux=disabled and all is working

So bug must be applied to SELinux, not to hal
Comment 4 shrek-m 2007-12-14 09:53:49 EST
i think it is really new problem, max. 1 week.

why? because the gnome-theme is changing too.
iirc a few days ago i got an other gnome-theme after the updates.
now with selinux=disabled i got the previous theme back.


# grep -i pol /var/log/yum.log
Dez 01 16:06:36 Updated: libsepol - 2.0.15-1.fc9.i386
Dez 01 16:10:05 Updated: libsepol-devel - 2.0.15-1.fc9.i386
Dec 04 17:33:17 Updated: policycoreutils - 2.0.32-2.fc9.i386
Dec 04 17:35:37 Updated: selinux-policy - 3.2.1-2.fc9.noarch
Dec 04 17:36:19 Updated: selinux-policy-targeted - 3.2.1-2.fc9.noarch
Dez 07 12:40:02 Updated: PolicyKit - 0.7-2.fc9.i386
Dez 08 00:13:03 Updated: PolicyKit - 0.7-3.fc9.i386
Dez 08 00:13:04 Installed: PolicyKit-gnome-libs - 0.7-1.fc9.i386
Dez 08 00:13:05 Updated: PolicyKit-gnome - 0.7-1.fc9.i386
Dec 08 15:43:49 Updated: selinux-policy - 3.2.2-1.fc9.noarch
Dec 08 15:44:23 Updated: selinux-policy-targeted - 3.2.2-1.fc9.noarch
Dez 11 21:12:53 Updated: libsepol - 2.0.16-1.fc9.i386
Dez 11 21:13:18 Updated: policycoreutils - 2.0.33-1.fc9.i386
Dez 11 21:20:25 Updated: selinux-policy - 3.2.3-1.fc9.noarch
Dez 11 21:21:01 Updated: selinux-policy-targeted - 3.2.3-1.fc9.noarch
Dez 11 21:21:05 Updated: libsepol-devel - 2.0.16-1.fc9.i386
Dez 12 15:14:12 Updated: policycoreutils - 2.0.33-2.fc9.i386
Comment 5 shrek-m 2007-12-17 12:17:11 EST
usb-stick, cd, gnome-theme, ... are ok
in SELinux permissive, targeted mode.
i can not test in enforcing mode.

the last updates:
Dez 17 14:06:35 Updated: policycoreutils - 2.0.33-3.fc9.i386
Dez 17 14:06:39 Updated: gmime - 2.2.12-1.fc9.i386
Dez 17 14:07:07 Updated: metacity - 2.21.3-1.fc9.i386
Dez 17 14:07:45 Updated: gnome-power-manager - 2.21.1-1.fc9.i386
Dez 17 14:07:50 Updated: selinux-policy - 3.2.4-2.fc9.noarch
Dez 17 14:07:51 Updated: gmime-sharp - 2.2.12-1.fc9.i386
Dez 17 14:08:15 Updated: selinux-policy-targeted - 3.2.4-2.fc9.noarch
Dez 17 14:08:16 Updated: intltool - 0.37.0-1.fc9.i386
Comment 6 antonio montagnani 2007-12-18 08:00:40 EST
I tested in Enforced mode and I get a kernel panic!!!! I am tired of SELinux and
I will get rid of it.
Comment 7 Bug Zapper 2008-05-14 00:12:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Alec Leamas 2008-05-19 11:34:11 EDT
Confirmed. I have the same problem - my USB disk which was identified and
mounted by rawhide immediately before the release is *not* mounted after the FC9
upgrade. 

Possibly related to that I've been forced to add a "service haldaemon restart"
to rc.local - the normal startup procedure seems to be broken after the Fedora 9
upgrade (see bug 443602).
Comment 9 Alec Leamas 2008-05-19 14:28:36 EDT
After boot, a "lvchange -a y /dev/lvm-volgroup" fixes the situation for me. 
Comment 10 Alec Leamas 2008-05-21 05:57:06 EDT
Fixed the haldaemon issue (see bug 443602), but the disk still need to be
activated in rc.local. 

Actually, this is some kind of regression. This bug occurred also in FC8, but
was fixed by one of the updates (sorry, no more specific information).
Comment 11 Alec Leamas 2008-05-21 06:09:05 EDT
Possibly related to that the hald daemon is started (as S26haldaemon) *after*
the netfs script (S25netfs). If so, this is consistent with the problems
reported in bug 443602.

Using "chkconfig netfs resetpriorities" does not help, though.

BTW, selinux is disabled...
Comment 12 Mike Pope 2008-06-02 07:50:46 EDT
Created attachment 307349 [details]
/var/log/messages, failing to mount a dvd

No removable devices (CD, DVD, USB) automount for me since F8->F9.  I restarted
hal with verbose logging, inserted a known working DVD, and the results in
/var/log/messages are attached.  I am on x86_64, kernel-2.6.25.3-18.fc9.x86_64,
mostly KDE, selinux enforcing but there is no audit chatter while plugging
devices.

Note You need to log in before you can comment on or make changes to this bug.