Bug 425081 - Please build krusader without kjsembed (kdebindings-devel)
Please build krusader without kjsembed (kdebindings-devel)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krusader (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 11:08 EST by Kevin Kofler
Modified: 2007-12-15 15:09 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.80.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-15 15:09:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-12-14 11:08:41 EST
Description of problem:
Krusader is currently the only application left (there was also kst, but that 
has already been changed) depending on the KDE 3 kjsembed (from the KDE 3 
kdebindings), which is no longer in the repository (we're shipping kdebindings 
4 now, without a compatibility package as nothing else in Fedora depends on 
the KDE 3 bindings). Krusader's kjsembed dependency is optional and, as far as 
I can tell, all we'll lose by disabling it is the JavaScript console intended 
mainly for testing:
http://krusader.sourceforge.net/handbook/javascript_console.html
And of course this problem will go away entirely once we'll have a KDE 4 
version of Krusader.

Version-Release number of selected component (if applicable):
krusader-1.80.0-3.fc9

How reproducible:
Always

Steps to Reproduce:
Look at the rawhide reports (broken dependencies) or try installing Krusader 
on rawhide.

Actual results:
krusader - 1.80.0-3.fc9.i386 requires libkjsembed.so.1

Expected results:
No broken dependencies

Note You need to log in before you can comment on or make changes to this bug.