Bug 42514 - iptraf from iptraf-2.4.0-1.i386.rpm (rawhide) isn't executable.
Summary: iptraf from iptraf-2.4.0-1.i386.rpm (rawhide) isn't executable.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: iptraf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-27 23:31 UTC by Peter H.S.
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-27 23:31:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter H.S. 2001-05-27 23:31:02 UTC
Description of Problem:
The binaries: "iptraf" and "rvnamed" in the iptraf-2.4.0-1.i386.rpm 
(rawhide) package, does not have the right permissions. Therefore the 
program can not be executed.
The program is installed with octal permission 100600 (read & write).


How Reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh iptraf-2.4.0-1.i386.rpm
2. /usr/bin/iptraf

Actual Results:
bash: /usr/bin/iptraf: Permission denied

Expected Results:
The program "iptraf" should start.

Additional Information:
This bug is submitted in the "Red Hat 7.1 Powertools" section, and not in 
the otherwise more appropriate "Red Hat Rawhide" section, since it was 
impossible to choose "iptraf" as a component there. (How about a Red Hat 
Rawhide Powertools section?)

The workaround for the rpm version, is simply to give appropriate 
executable permissions to the files /usr/bin/iptraf and /usr/bin/rvnamed. 
For security reasons, probably only root should be able to use this 
program on multi-user systems.

Comment 1 Karsten Hopp 2001-05-28 08:24:13 UTC
Fixed in iptraf-2.4.0-3.i386.rpm



Note You need to log in before you can comment on or make changes to this bug.