Bug 42516 - Installer crashed during /var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py
Installer crashed during /var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 19:47 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-30 23:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-27 19:47:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in 
doInstall
    (p, self.intf.messageWindow, pkgTimer))
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1564, in 
instCallback
    fn = self.method.getFilename(h, pkgTimer)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 82, in 
getFilename
    f = open("/mnt/source/" + key)
IOError: [Errno 2] No such file or directory: '/mnt/source/.disc1-i386'

Local variables in innermost frame:
timer: <timer.Timer instance at 9dbb550>
self: <image.CdromInstallMethod instance at 8548770>
key: .disc1-i386
h: <header object at 87c59e0>

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I457
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>


How reproducible:
Always

Steps to Reproduce:
1.after server option and packages is chosen, running install gets about 
75% of the way done
2.
3.
	

Additional info:
Comment 1 Timothy Ericson 2001-05-27 23:50:22 EDT
I Get that same problem. I installed 7.1 once and it worked, then i need to 
take it off for another reason. Then i tried to install it again using the same 
disk and it doesn't work. It happens evertime and not just in the Server 
installation but also the workstation! PLEASE FIX!
Comment 2 Need Real Name 2001-05-30 16:56:54 EDT
The installation halts on any computer, doing any type of installation with any 
different components selected during the text-fonts package. Can anyone help 
please?!!
Comment 3 Brent Fox 2001-05-30 23:17:33 EDT
Can either of you look at VC3 and VC4 and see if you see any error messages
about reading the cd?
Comment 4 Need Real Name 2001-05-30 23:51:28 EDT
I recieved an email today from the person I recieved the disks from. Turns out 
they were currupted burns.
Comment 5 Brent Fox 2001-05-31 14:26:25 EDT
timeri, it sounds like there could be inconsistencies on your disks as well. 
The fact that installation worked for you before but not later makes me think
that this is the case.

Note You need to log in before you can comment on or make changes to this bug.