Bug 425361 - mock-helper/chroot shows host os's arch, not the buildroot
mock-helper/chroot shows host os's arch, not the buildroot
Status: CLOSED CURRENTRELEASE
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 14:42 EST by BJ Dierkes
Modified: 2013-01-09 23:31 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 16:51:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BJ Dierkes 2007-12-14 14:42:16 EST
Description of problem:

Running commands like 'arch' or 'umask' obviously show the arch of the Host OS.
 In most cases this doesn't matter, however I have found that I can not build
PHP-5.2.5 on RHEL5 i386 because of the way net-snmp-config determines the arch
of the OS (using the 'arch' command).  net-snmp-config believes the build arch
is x86_64 (that of the host OS) and not i386 (the OS I'm building for) because
it is using the 'arch' command to determine arch.


Version-Release number of selected component (if applicable):

mock-0.7.2-2.rs


How reproducible:

Every time.


Steps to Reproduce:
1. mock -r <rhel5-i386-config> rebuild php-5.2.5-1.src.rpm
2.
3.
  
Actual results:

checking whether libxml build works... (cached) yes
checking for SNMP support... yes, shared
checking OpenSSL dir for SNMP... no
checking whether to enable UCD SNMP hack... yes
/usr/bin/net-snmp-config: line 43: net-snmp-config-x86_64: command not found
/usr/bin/net-snmp-config: line 43: net-snmp-config-x86_64: command not found
/usr/bin/net-snmp-config: line 43: net-snmp-config-x86_64: command not found
configure: error: Could not find the required paths. Please check your net-snmp
installation.



Expected results:

net-snmp-config should see that the installed arch is i386... but the arch/uname
commands show x86_64 (the host OS arch).


Additional info:
Comment 1 Clark Williams 2008-03-07 16:51:54 EST
The latest version of mock does an internal 'setarch' that should now show your
arch as i386

Note You need to log in before you can comment on or make changes to this bug.